5 Replies Latest reply: Dec 22, 2015 7:05 PM by Stefan Wühl RSS

    How to remove trailing zeroes?

    Benny Lu

      I'm pulling data from Oracle and I'm getting this weird scenario. I'm pulling a field that is of NUMBER data type in Oracle and yes I've made certain it's a NUMBER data type. The value in Oracle is 29.94. When I run it on my local machine, I get the attached result (note it's not all zeroes, there's a "1" as well.

       

      I can suppress the zeroes by changing it on the Number tab in the object's properties but this is not what I want. If I go to Table Viewer and preview the data, it is still showing the zeroes.

       

      I reloaded this same qvw on one of our dev servers and it displays the correct value in the object and Table Viewer. This data set is huge so getting rid of these trailing zeroes would be extremely beneficial. I have tried the CAST and TRUNC functions in the SQL select to no avail.


      I can only think it's either a Qlikview or system setting that's causing the zeroes on my machine and not the dev server.


      Thanks

       

      extra_zeroes.PNG