4 Replies Latest reply: Dec 17, 2010 8:22 AM by Cesar Accardi RSS

    Scheduling a Reload fails

      Hey all,

      I am trying to schedule a reload. It doesn't matter which document I try to schedule, they all fail and this is what they say:

      Summary could not be compiled because this task belongs a Distribution Service which is not managed by the Command Center.

      The log says this:

      (2010-01-08 09:00:20) Information: Executing ClusterID=1, QDSID=daec3b6a-ba7b-641e-ca9e-d7bf9513a850QDSMain.ReloadTask

      (2010-01-08 09:00:20) Information: Starting task "Utility/UpdateAndStore/UpdateSFCase.qvw" (Attempt 1 of 1)

      (2010-01-08 09:00:20) Information: Max run time: 06:00:00

      (2010-01-08 09:00:20) Information: Opening "C:\ProgramData\QlikTech\Support\QVW\Utility\UpdateAndStore\UpdateSFCase.qvw"

      (2010-01-08 09:00:20) Information: Allocating QlikView Engine

      (2010-01-08 09:00:20) Information: Allocating new QlikView Engine. Current usagecount=1 of 2

      (2010-01-08 09:00:20) Information: An instance of the QlikView Engine is being created

      (2010-01-08 09:00:20) Information: Starting QlikView Engine

      (2010-01-08 09:00:20) Information: The QlikView Engine was started successfully. Version=9.00.7320.7, ProcessID=1212

      (2010-01-08 09:00:20) Information: Allocated QlikView Engine successfully. Current usagecount=1 of 2, Ticket=5

      (2010-01-08 09:00:20) Information: Loading document "C:\ProgramData\QlikTech\Support\QVW\Utility\UpdateAndStore\UpdateSFCase.qvw" (0.11 Mb)

      (2010-01-08 09:00:20) Information: Physical FileSize=0.11 Mb. Memory Allocation Delta for this file=3.73 Mb. Available Physical Memory Before Open=1165.19 Mb. Available Physical Memory After Open=1162.03 Mb. Total Physical Memory=2047.34 Mb.

      (2010-01-08 09:00:20) Information: The document was loaded successfully.

      (2010-01-08 09:00:21) Information: Initializing Checkout (0), Loading document (281), Initializing load (281), Checking read (281), Creating QlikView Engine (281), Checking Size (375), Load (375), Load Completed (437), Tables read (469), Opened successfully (500)

      (2010-01-08 09:00:21) Information: Document was opened successfully

      (2010-01-08 09:00:21) Information: Opened successfully (0)

      (2010-01-08 09:00:21) Information: Starting reload

      (2010-01-08 09:00:21) Information: QlikView->Settings->Document Peferences->Generate Logfile in document is not set.

      (2010-01-08 09:00:21) Information: The Source Document is being reloaded. DocumentPath=C:\ProgramData\QlikTech\Support\QVW\Utility\UpdateAndStore\UpdateSFCase.qvw

      (2010-01-08 09:00:21) Information: The Source Document reload complete. DocumentPath=C:\ProgramData\QlikTech\Support\QVW\Utility\UpdateAndStore\UpdateSFCase.qvw

      (2010-01-08 09:00:21) Information: Memory Allocation Delta for this file=0.37 Mb. Available Physical Memory Before Reload=1162.00 Mb. Available Physical Memory After Reload=1161.18 Mb. Total Physical Memory=1161.18 Mb.

      (2010-01-08 09:00:21) Error: The Source Document was NOT reloaded successfully. DocumentPath=C:\ProgramData\QlikTech\Support\QVW\Utility\UpdateAndStore\UpdateSFCase.qvw.

      (2010-01-08 09:00:21) Information: Initializing Reload (0), Finished (343)

      (2010-01-08 09:00:21) Error: Reload failed.

      (2010-01-08 09:00:21) Information: Closing the document.

      (2010-01-08 09:00:21) Information: Closed the QlikView Engine successfully. ProcessID=1212

      (2010-01-08 09:00:21) Information: Initializing (0), Finished (203)

      (2010-01-08 09:00:21) Error: The task "Utility/UpdateAndStore/UpdateSFCase.qvw" failed. ErrorCount=2

      (2010-01-08 09:00:21) Information: Sending Alert Mail to 1 recipients.

      Here are my system details:

      Qlikview Management Service
      Product Information
      Product Name QlikView Management Service
      Client Build Number 9.0.7320.7
      Target Platform
      Machine Information
      Computer Name SLC-SUPPORT-QVS
      Operating System Version Microsoft Windows Server 2003 R2 Standard x64 Edition X64 (Microsoft Windows NT 5.2.3790 Service Pack 2)
      .NET Version 2.0.50727.3082
      Physical Memory 2047Mb
      Available Memory 1178Mb
      CPU Information
      CPU 0 Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz
      CPU 1 Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz

      I am reading the QVS guide trying to figure out what I need to do but it is not obvious to me yet. Any help would be appreciated.

        • Scheduling a Reload fails

          Never mind.

          I lied. Not all documents were failing...just ones connecting to Salesforce.

          Turns out I needed to copy the copy the SalesForceDLL.dll to the C:\Program Files\QlikView\Publisher\Distribution Service folder and then I restarted the services and everything is working.

          I think that the act of gathering the data to make a community post is what helped me take the next step to making this realization. So if I hadn't posted, I wouldn't have figured it out.

            • Scheduling a Reload fails

              Hi Jared,

              glad to hear you solved your problem yourself... maybe you can help me with mine. :-)

              I get the same error on the status tab as you do which makes it difficult to track down errors:

              "Summary could not be compiled because this task belongs a Distribution Service which is not managed by the Command Center."

              Have you been able to solve this one as well?

              Cheers, Lukas

                • Scheduling a Reload fails
                  Colin Hancox

                  Hi

                  Does anyone have any more information on this problem? I am getting the same error message in the Task log. The Status page on the Management Console shows the documents as having been loaded as scheduled, with no errors, but they were not loaded.

                  Strangely, last week the documents were showing that they had been reloaded in the future. All documents were showing a reload date of 17 July 2010. The system date and time on the server are accurate. Manually reloading through the Management Console fixed this, but now the documents will not reload as scheduled.

                  Thanks.

                    • Scheduling a Reload fails
                      Cesar Accardi

                      Hi Jared.

                      I had a similar problem. When I tried to reload the documents through the QVS i got the error message

                      "The Source Document was NOT reloaded successfully. DocumentPath=E:\CargaRH.qvw.
                      Reload failed.
                      The task "CargaRH.qvw" failed. ErrorCount=2"

                      At first I thought that the problem was the ODBC connection. After doing some tests in the server I noticed that the connection was working properly. I also tryied to reload a Document without ODBC connections and I still got the error. Finally, I found that the problem was the files path.

                      I was trying to reload from my QVD's this way:

                      LOAD ... FROM [..\QVD\RH_Dados_Folha.qvd]

                      When Reloading through the desktop installation (local to the server) it worked but not in QMC. So I wrote the script like this:

                      LOAD ... FROM [QVD\RH_Dados_Folha.qvd]

                      Regards,