12 Replies Latest reply: Feb 1, 2010 6:01 AM by Nicolas MARTIN RSS

    Can't access to the console

    Nicolas MARTIN

      Hi !

      I've just installed the QlikView Server on a computer (a virtual machine in fact).

      After the installation, I want to setup my licence and my directories with the QV Management Console.

      I go to the URL

      http://localhost:4780/qmc/default.htm

      or

      http://vmw-xp:4780/qmc/default.htm

      and I have a popup that asks me a login / password :

      error loading image

      I only have 1 account on this computer : "Administrateur", the administrator account.

      I tried "vmw-xp\Administrator", "Administrateur@vmw-xp", "Administrateur", ... nothing works. I can't access to the page.

       

      Am I the only one to have this problem ?

      I tried to uninstall, install IIS, reinstall QV WS, but nothing works.

      The VM is a Windows XP pro.

        • Can't access to the console
          Vlad Gutkovsky

          A local group was created during the installation called "QlikView Administrators." Add your account into that group and then try logging in again.

          Regards,

            • Can't access to the console
              Nicolas MARTIN

              This user is already in the "QlikView Administrator" group.

                • Can't access to the console
                  Rob Wunderlich

                  Did this machine have a previous intallation of QVS? If so, after uninstall, completley remove (or rename) the flolder

                  \Documents and Settings\All Users\Application Data\QlikTech

                  and then reinstall

                  -Rob

                    • Can't access to the console
                      Nicolas MARTIN

                      It was a brand new install of WinXp.

                       

                        • Can't access to the console
                          Vlad Gutkovsky

                          Is it possible that "Administrateur" is only the display name of the user, and the real user name is "Administrator" (i.e. the built-in account)?

                          Another likely solution is that you configured IIS incorrectly. If it's configured correctly, you should be able to stop the QV Web Server service and still retain full functionality. If this is not the case, let me know and I'll walk you through what needs to be done.

                          Thanks,

                            • Can't access to the console
                              Nicolas MARTIN

                              I thought that when I use the "http://localhost:4780/qmc/default.htm", it's the Management Console only available by the QV Server, not the IIS server.

                              Am I wrong ?

                               

                              My QV Web Server is not started, because IIS is already started.

                               

                                • Can't access to the console
                                  Vlad Gutkovsky

                                  No, that's not correct. When you switch over to IIS your management consoles are also switched over to IIS control. To start troubleshooting IIS, can you first tell me which version of QVS you're using (GA, SR1, or SR2)?

                                  Regards,

                                    • Can't access to the console
                                      Nicolas MARTIN

                                      I don't know wich version of QVS I'm using. I've downloaded "QvsSetupRedist.exe" on monday (january the 25th 2010).

                                      The file says only "9.0.7320.7".

                                       

                                      I think I've misinterpreted this schema :

                                       

                                       

                                      I though that the "Management Console" and "Enterprise Management Console" were handled by the QV Management Service, this one listening on the 4780 port (even if I'm using IIS), that's why the URL are :

                                      http://localhost:4780/qemc/
                                      and
                                      http://localhost:4780/qmc/

                                       

                                      When I go to the IIS console (version 5.1), I don't see the "qemc" and 'qmc" folders / links :

                                       

                                      (another reason that makes me think it's handled by another service)

                                       

                                      When I try to acces to this URL, I have the popup asking me a username and a password, I can pass throught.

                                       

                                      When I go to the URL http://localhost/QlikView/ (managed by IIS), I have the toolbar menu, but empty :

                                      After a few seconds, I've a

                                      message.

                                       

                                      I tried to change the security parameters

                                      But checking / unchecking "anonymous connection" doesn't change a thing (except somethimes, I don't have access at all at the page)...

                                       

                                       

                                        • Can't access to the console
                                          David Vasseur

                                          Do you have a password defined for your administrator account ? You need to have one (not blank) otherwise Windows won't let you log in

                                            • Can't access to the console
                                              Nicolas MARTIN

                                              Yes, I have a password.

                                              I tried to logon with :
                                              - [Account]
                                              - Paradise\[Account]
                                              - 127.0.0.1\[Account]
                                              - [Domain]\[Account]
                                              - localhost\[Account]
                                              - .\[Account]

                                                • Can't access to the console
                                                  Vlad Gutkovsky

                                                  Sorry, I misinterpreted your question before--you are correct that in v9 QEMC and QMC are published by a different service called the QlikView Management Service. When you go to http://locahost/qlikview, that opens the AccessPoint and is not for management purposes. However, after reading your post I suspect that your IIS is indeed set up incorrectly. This could be causing all the issues you're having. You are running SR2, so here is the procedure you need to follow to correctly set up IIS (you may want to start with a clean installation of QVS, by uninstalling and deleting all files left over in Documents and Settings\All Users\QlikTech and the registry key HKEY_LOCAL_MACHINE\SOFTWARE\QlikTech\QlikViewServer):

                                                  1. Install with the IIS option selected during installation.
                                                  2. After installation, create a new application pool in IIS (it could be named anything). Change the Identity of the pool to the same account used when installing QVS.
                                                  3. Change the application pool for the virtual folder /QvAJAXZFC from "Default AppPool" to the one created above.
                                                  4. Since you can't open QEMC to edit some settings, we need to edit some files manually. Stop the QlikView Management Service, the Publisher CommandCenter Service and the QlikView WebServer Service. Open the file C:\ProgramData\QlikTech\Publisher\CommandCenter\QVPR\QvWebServiceResource.xml (or C:\Document and Settings\All Users\QlikTech\Publisher\CommandCenter\QVPR\QvWebServiceResource.xml). Line 22 should contain the only entry. Replace the ServerAddress with the following: ServerAddress="http://localhost/QvAJAXZFC/AccesspointSettings.aspx"
                                                  5. Save and close the QvWebServiceResource.xml file.
                                                  6. Start the QlikView Management Service and the Publisher CommandCenter Service. Do NOT start the WebServer. Change the WebServer service to manual startup and leave it stopped.

                                                  That's the entire procedure for switching over to IIS if you have v9. Hopefuly that should solve the login problems as well. If you need help setting up tunneling or anonymous access later, I'd be glad to help you out.

                                                  If this still does not fix the problem, the only other thing I can think of is to try adding the server into the Trusted Sites list in IE.

                                                  Let me know how it goes.