5 Replies Latest reply: Feb 12, 2010 12:04 PM by Vlad Gutkovsky RSS

    Problem to open document with IE Plugin

      Hello,

      i've got lot of problem to open document with IE plug in.

      I have seen IE Plugin try to communicate with qvstunnel.dll, but he try on the port 80 after on the 8080 and after on the port 4747. I think he lost lot of time try to communicate with the 3 ports.

      Configuration :Qlikview 9 SR2, server 64 bit windows 2003, IIS install and service start, no firewall between server and client.

      Have you got any idea to configure something to force IE plug in to check only one port ?

      Thanks

        • Problem to open document with IE Plugin
          Vlad Gutkovsky

          To answer your question, just disallow the tunnel extension in IIS. Also under QEMC --> System --> QlikView Servers --> Security, uncheck "Enable server push over HTTP tunnels." That should force it to try only your QVS port (4747 by default).

          Regards,

            • Problem to open document with IE Plugin

              thanks, this option is no check.

              But i have particular procedure to access document like this :

              var client = "plugin";
              var url;
              if (client == "java")
              url = "/Qvjava/opendoc.htm?tunnel=&document="+doc+"&ticket=";
              else if (client == "plugin")
              url = "/QvPlugin/opendoc_fix.htm?tunnel=&document="+doc+"&ticket=";
              else
              url = "/QvAJAXZfc/opendoc.htm?document="+doc+"&ticket=";

              This code force qlikview to use the tunnel, so i have changed for plugin issue : url = "/QvPlugin/opendoc.htm?document="+doc+"&ticket=";

              It worked.

              But the acces to the document it's too long ! I don't find documentation about function opendoc_fix.htm.

                • Problem to open document with IE Plugin
                  Vlad Gutkovsky

                  Yeah, there is virtually no documentation for HTM files in QlikView.

                  Actually, if you had disabled tunneling in IIS your code would not have been able to use the tunnel, but it's good that you cleaned it up a bit. You said before that there is no firewall--did you make sure to disable Windows firewall as well (both server- and client-side)? The reason I'm asking is that QlikView will use 4747 by default unless it's unavailable and only then will it switch to tunneling. So test communications on that port...

                  Another thing: is it possible that the delay is caused by large file size, rather than any network issues? It could just be that a big file takes a while to load...

                  Regards,

                    • Problem to open document with IE Plugin

                      Hello,

                      Windows firewall are not active on client and server.

                      Maybe the application it's large application => 1,7 Go

                      Now, I know the acces take directly the port 4747 but i have one more error message on the conversation between the client and the server :

                      HTTP: GET /QvClients/settings.js HTTP/1.0
                      --------------------------->(8080)
                      TCP: http-alt > vrts-ipcserver [ACK] Seq=1 Ack=1642 Win=65535 Len=0
                      ----------------------------(8080)
                      TCP: [TCP segment of a reassembled PDU]
                      ----------------------------(8080)
                      HTTP: HTTP/1.1 401 Unauthorized (text/html)

                      The error is HTTP 401 after the call of settings.js.

                      Have got any idea to resolve this problem ?

                        • Problem to open document with IE Plugin
                          Vlad Gutkovsky

                          settings.js by default is entirely commented out so would be seem like a blank file. This is used for changed the communications port when using IIS. So I wouldn't worry about this file, it's pretty harmless.

                          The unauthorized http traffic is completely normal. That's the auth handshake, and always comes back unauthorized at first.

                          If your application is 1.7 GB, it's definitely going to take a while to open just because of network communication delays (even if the file is preloaded in server memory). This also seems completely normal to me. So, basically, I don't think you actually have any problems Smile

                          Regards,