18 Replies Latest reply: Mar 1, 2010 1:19 PM by Jake Bingen RSS

    Section Access> Reload not Successfull

      I am having issues with Publisher reloading the QV document. I have section access in the document. I have read the Section 27: Section Access in the QV Server and I figure I am missing something in the guide just unsure of what it is.

      Publisher settings> QV Enterprise Management Console> System> Distribution Services> Advanced> I have entered in my admin name/password in the Section Access section on the server. I have setup a task for the QVTest document to reload and have placed the same name/password in the section access part of the task wizard. It can open the document but the log file generates this:

      2/25/2010 11:09:03.1077908 Error The Source Document was NOT reloaded successfully. DocumentPath=C:\ProgramData\QlikTech\Documents\QVTest.qvw.
      2/25/2010 11:09:03.1337934 Information Document log "C:\ProgramData\QlikTech\Documents\QVTest.qvw.log" was not found / not updated. Skipped.
      2/25/2010 11:09:03.1367937 Information Initializing Reload (0), Finished (814)
      2/25/2010 11:09:03.1397940 Error Reload failed.
      2/25/2010 11:09:03.1527953 Information Closing the document.
      2/25/2010 11:09:03.3138114 Information Closed the QlikView Engine successfully. ProcessID=5916
      2/25/2010 11:09:03.3178118 Information Initializing (0), Finished (174)
      2/25/2010 11:09:03.3208121 Error Reload failed. Distribution skipped.
      2/25/2010 11:09:03.3288129 Error The task "Reload of QVTest.qvw" failed. ErrorCount=3

      Section access code in my QV document. Links up to below Excel spreadsheet.

       


      Security:
      SECTION ACCESS;
      Directory;

      LOAD [USERID],
      [PASSWORD],
      [ACCESS],
      [GROUP]
      FROM
      [C:\Users\username\Documents\security_all.xlsx]
      (ooxml, embedded labels, table is Users);

      Section Application;
      Directory;
      LOAD [GROUP],
      HowTo,
      Dashboard,
      SalesScreen,
      Sales,
      Transaction,
      OrderDetail,
      SLX,
      SLXPreformance,
      SLX_Shannon_Joan,
      InterestFields
      FROM
      [C:\Users\username\Documents\security_all.xlsx]
      (ooxml, embedded labels, table is Matrix);


      Spreadsheet were Section Access sheets/users are being pulled from:

      [View:http://community.qlik.com/cfs-file.ashx/__key/CommunityServer.Discussions.Components.Files/12/6354.security_5F00_all.xlsx:550:0]

      If you have any other questions let me know.

      Thanks for any help on this matter.

        • Section Access> Reload not Successfull
          Vlad Gutkovsky

          Jacob,

          Instead of entering the admin section access info into the server, try the opposite: enter the publisher user account (either with NTName or SecurityIdentifier) into the section access of the document. For whatever reason, putting the admin info into the server does not always work...

          Regards,

            • Section Access> Reload not Successfull

              I assume the Publisher user account is the account I used to install Qlikview Server with?

              Otherwise where do I find the publisher account? Once I do find this account put it on my excel sheet and give it 'ADMIN' access?

              At this time I do not use the domain for authentication to QV, through I installed QV using a domain account, does this matter?

              I need more explanation.

              Thanks.

                • Section Access> Reload not Successfull

                  I read some other forums relating to this and apparently this is a more common issue.

                  I have added the 'publisher account' to Section Access in the excel spreadsheet.

                  This does not seem to be working. I know the account is in in the qvw because I can log in with it. I then entered this account into the task as and into the QDS on the server. I know this is the correct account because all the services are for QV are using it. I also tried using domain\MOSS_Setup and this did not work either.

                  Excel sheet:

                   

                  USERIDPASSWORDACCESSGROUP
                  ADMIN123ADMIN
                  joejoeUSERGROUP1
                  johnjohnUSERGROUP1
                  dennisdennisUSERGROUP1
                  crmcrmUSERGROUP1
                  allallUSERGROUP2
                  MOSS_SetuppasswordADMIN

                  Any other ideas? Am I still missing something?

                    • Section Access> Reload not Successfull
                      Vlad Gutkovsky

                      Jacob,

                      It's not a UserID. The Publisher account (yep, the one you used to set up QlikView) is a Windows account, which must be specified in section access either as NTNAME or NTDOMAINSID (see pages 507 & 509 of the QlikView Reference Manual). The fields are not case sensitive. I prefer to use the SID because you avoid confusion with specifying domain names. In particular, see page 509 which will show you how you can have a table that includes mixed UserIDs and Windows qualifiers through the use of asterisks.

                      Regards,

                        • Section Access> Reload not Successfull

                          Updated Excel spreadsheet matching QV Reference Manual. I can log in with moss_setup into the qvw so I know the SID number is correct and working. Loading still fails with same error code.

                          Thanks for your help thus far. I believe we are very close.

                          USERIDPASSWORDACCESSGROUPNTDOMAINSID
                          ADMIN123ADMIN**
                          joejoeUSERGROUP1*
                          johnjohnUSERGROUP1*
                          dennisdennisUSERGROUP1*
                          crmcrmUSERGROUP1*
                          allallUSERGROUP2*
                          *passwordADMIN*S-1-5-21-789336058...
                            • Section Access> Reload not Successfull
                              Vlad Gutkovsky

                               

                              You need to put the following statement into your script before you load the table: Star is *;

                              Also, looks like the first entry (ADMIN) is messed up--the password is under the access field and the password field is empty. Or is that just a typo?

                              Regards,

                                • Section Access> Reload not Successfull

                                  Password for ADMIN is 123 just right aligned rather than left...

                                  I put Star is*; in code. Is this the correct location? I did not see this referenced in the reference guide?

                                   


                                  Security:
                                  SECTION ACCESS;
                                  Star is *;
                                  Directory;
                                  LOAD [USERID],
                                  [PASSWORD],
                                  [ACCESS],
                                  [GROUP],
                                  [NTDOMAINSID]

                                  FROM
                                  [C:\Users\jjbadmin\Documents\security_all.xlsx]
                                  (ooxml, embedded labels, table is Users);

                                  Section Application;
                                  Directory;
                                  LOAD [GROUP],
                                  HowTo,
                                  Dashboard,
                                  SalesScreen,
                                  Sales,
                                  Transaction,
                                  OrderDetail,
                                  SLX,
                                  SLXPreformance,
                                  SLX_Shannon_Joan,
                                  InterestFields
                                  FROM
                                  [C:\Users\jjbadmin\Documents\security_all.xlsx]
                                  (ooxml, embedded labels, table is Matrix);


                                  Did not work. Same error code.

                                    • Section Access> Reload not Successfull
                                      Vlad Gutkovsky

                                      It's referenced on page 509. The location should be correct (although you can delete the Directory statement entirely). Strange that this isn't working since your syntax should be correct. Try this: log in to Windows using the Publisher account and reload the document in QV Desktop. This should recreate what happens when Publisher reloads the QVW. If it works, the problem might be with Publisher itself and not section access...

                                      Regards,

                                      • Section Access> Reload not Successfull

                                        Okay new error code.

                                        Reload failed because the document could not be opened successfully. DocumentState=CouldNotOpenDocument

                                        The task "ReloadAgain" failed. ErrorCount=5

                                        Passwords are correct, checked twice. Logged in to server as my admin account not as moss_setup? Could this be an issue? I will play with it some more. Keep you posted.

                                          • Section Access> Reload not Successfull

                                            Yes you are correct. I can no longer log into my QVW using moss_setup account. I also can not access the document logging into the server with moss_setup.

                                            All documents were created with my admin account. Was I supposed to use the moss_setup account to create qvw's?

                                             

                                              • Section Access> Reload not Successfull
                                                Vlad Gutkovsky

                                                The Publisher account (MOSS_SETUP in your case) should be a local admin so that it has access to all documents. Check the NTFS security and make sure it has Read & Execute permissions on that file. It doesn't matter what account you use to create the QVW, as long as the Pub account has the proper permissions.

                                                  • Section Access> Reload not Successfull

                                                    Yeah.

                                                    moss_setup is a local admin and I gave 'full control' to the qvw.

                                                    I do not know what else it could be. Something must be being getting read incorrectly since I can no longer log into the qvw with the moss_setup account.

                                                    The domain password for moss_setup and the password in the Excel sheet for Section Access are the same. Does this matter?

                                                     

                                                      • Section Access> Reload not Successfull
                                                        Vlad Gutkovsky

                                                        If you specify the SID you actually don't need any password I believe. Have you checked the source files that the QVW is loading from? Does MOSS have access to those files as well?

                                                          • Section Access> Reload not Successfull

                                                            I do not know if this matters but every time I open up the qvw after I close Qlikview completely it asks if I want to save the qvw again before I do reload. Does this mean anything? I remember from the training this is supposed to happen but I forget the reason why.

                                                            I attempted to remove the password value, put a blank value in the password. None of this worked and same error message was received.

                                                            Just to confirm. I currently have moss_setup credentials in both the QDS and the task. This is correct?

                                                            Should moss_setup account be able to log into the qvw? Currently it can not do so. Which is most likely why the log says "error The document failed to open. Bad Username and password is the most likely cause of this problem. " Through it is not a bad password. I copied and pasted.

                                                            I gave full rights to moss_setup on the excel sheet. The rest of the data is being pulled from the SQL DB. Do I need to add moss_setup to the SQL DB? This does not seem right.

                                                            Anything else to look at?

                                                              • Section Access> Reload not Successfull
                                                                Vlad Gutkovsky

                                                                You do need to give the Publisher account access to your DB of course. And, no, the MOSS account should only be in the section access, not the task. If you can't even open the file under MOSS then it's definitely going to fail so don't even bother trying the task again until you can open and reload it with MOSS. Trying adding the NTNAME in addition to the SID. Section Access definitely supports both, so it's just a matter of playing around with it until you get the correct credentials. You'll know it's correct when it works :)

                                                                Regards,

                                                                  • Section Access> Reload not Successfull

                                                                    Just a thought.

                                                                    Am I supposed to configure Directory Service Connectors > Active Directory > to be our domain? This does not seem to be working. Lots of errors in the Event Viewer. Would QV not having a connection to AD be why moss_setup a domain account on AD not being read?

                                                                    Thanks.

                                                                      • Section Access> Reload not Successfull
                                                                        Vlad Gutkovsky

                                                                        No that shouldn't be the problem. You only need to have that configured to use the distribution feature in Publisher, but just reloading doesn't modify NTFS security so it shouldn't matter. I think when you get the file to reload through Desktop while you're logged in as MOSS you'll be well on your way to fixing the problem. So I would say focus on that now.

                                                                        Regards,

                                                                          • Section Access> Reload not Successfull

                                                                            Thanks Vlad for all your assistance on this post. Hopefully this forum can help many other as well.

                                                                            I attempted to use NETDOMAINSID, just NTNAME by itself and many other combination. The correct combination was NTMAME and NTSID. I also had to recreate my QVW in the same account I use to run the QV Server. This was the moss_setup.

                                                                            Below is the solution that worked for me.

                                                                            Final Section Access Code.

                                                                             


                                                                            Security:
                                                                            SECTION ACCESS;

                                                                            LOAD * inline [
                                                                            NTSID,USERID, PASSWORD,ACCESS,GROUP, NTNAME
                                                                            *, ADMIN, 123, ADMIN, *, *
                                                                            *, joe, joe, USER, GROUP1, *
                                                                            *, john, john, USER, GROUP1, *
                                                                            *, dennis, dennis, USER, GROUP1, *
                                                                            *, crm, crm, USER, GROUP1, *
                                                                            *, all, all, USER, GROUP2, *
                                                                            S-1-5-21-789336058-113007714-839522115-1253, *, password, ADMIN, *, moss_setup
                                                                            ];

                                                                            Section Application;
                                                                            LOAD * inline [
                                                                            GROUP, HowTo, Dashboard, SalesScreen, Sales, Transaction, OrderDetail, SLX, SLXPreformance, SLX_Shannon_Joan, InterestFields
                                                                            GROUP1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1
                                                                            GROUP2, 1, 1, 0, 0, 1, 0, 1, 1, 1, 0
                                                                            ];


                                                                            Hope this helps someone in the future.

                                                                            Thanks.