4 Replies Latest reply: Mar 15, 2010 12:05 PM by Arturo Perez RSS

    Server will not reload QVW applications

    Arturo Perez

      I'm having an odd issue and wonder if you have seen this before.

      To get some history, please view this post first. It details history relevant to this issue.

      http://community.qlik.com/forums/p/25707/98287.aspx#98287

      After all that happened, now I noticed that the reload functionality is not working properly. We can't schedule reloads and immediate reloads don't always work.

      My concern now is that the Qlikview Server uninstaller didn't fully clean out the registry and or other files. I don't believe the reload is ever being started, but the server tells me it is reloading.

      Any help or advice would be highly appreciated.

      Thank you,

      Arturo

       

        • Server will not reload QVW applications
          Arturo Perez

          I'm now having the same issue on our QA server but that I never changed the name on that server. I have just noticed that we're getting this error on both our QA and Live servers. We don't have load balancing turned on either server. They are configured with the standard configs.

          3/2/2010 07:32:21.3137500 Error LoadBalancer.xml: ClusterFileLock: Dispose. Exception=System.UnauthorizedAccessException: Access to the path 'C:\Documents and Settings\All Users\Application Data\QlikTech\Publisher\Qlikview Distribution Service\LoadBalancer.xml.old' is denied.

          at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

          at System.IO.File.Delete(String path)

            • Server will not reload QVW applications
              Arturo Perez

              We believe these issues started on 3/1. We tested the distribution service by using the command line EXE and were able to confirm it works. It appears the issue is that the Management Consoles are not communicating with the Distribution service.

                • Server will not reload QVW applications
                  kat-ris

                  Not sure if your issue is similar to the one I had. For me all services were running, but when I tried to schedule a reload it didn't appear on the list and automated reloads where not working. It worked if it was manually invoked by pressing 'Reload Now'.

                  For that problem the solution was to go to the Enterprise Management Console and untick 'Allow only one copy in memory' setting'. Might be worth giving it a go, although if your distribution service is not working properly or connecting to the management console, it's likely to be a different problem.

                  Katerina

                    • Server will not reload QVW applications
                      Arturo Perez

                      Well, the issue turned out to be our Virus Scanning software. We are running MicroTrend and it was locking up some files that Qlikview was using. Why do I feel like I've heard this story before?

                      A new profile was pushed out March 1st and that's when things started breaking. I hope this helps someone.