0 Replies Latest reply: Jan 29, 2016 1:33 PM by Amirali Vastani RSS

    11.2 SSO Solution using Apache ProxyPass

    Amirali Vastani

      Hi,

       

      I have a unique case where SSO is setup successfully with IIS using WebTickets and Header Authentication.

       

      The problem is with the URL, whereby it only works if I supply the IP Address of the QV Server and does not work if I use a ProxyPass from Apache.

       

      My setup is below

       

      1. SSO handles authentication

      2. User is logged into a domain portal hosted on Apache

      3. User clicks on a button to launch Accesspoint

      4. Accesspoint hangs as Loading Content when I use the URL of the apache server

       

      Apache server is setup to have Proxy Pass shown below. Am I missing something that IP Address works but the Apache adddress does not? Even though it is configured to send the traffic to the QV Server? I don't want to show the server IP in the URL. How can this be made possible?

       

      #############################################

      # QlikView

      #############################################

      <LocationMatch /qlikview/>

          Order allow,deny

      Allow from all

      #SSLVerifyClient require

      #SSLVerifyDepth  10

      # Trust client certificates

      #SSLRequire (%{SSL_CLIENT_S_DN_CN} eq "xx.xxxxx")

      ProxyPass http://[QVServerIP]/qlikview/

      </LocationMatch>

       

      #############################################

      # QlikView

      #############################################

      <LocationMatch /QvAjaxZfc/>

          Order allow,deny

      Allow from all

      #SSLVerifyClient require

      #SSLVerifyDepth  10

      # Trust client certificates

      #SSLRequire (%{SSL_CLIENT_S_DN_CN} eq "xx.xxxxx")

      ProxyPass http://[QVServerIP]/QvAjaxZfc/

      </LocationMatch>