1 Reply Latest reply: Feb 18, 2016 9:29 AM by Levi Turner RSS

    Legacy mode activation on the Qliksense server does not give desired results?

    Balraj Prabhu

      I have enabled the legacy mode on qliksense desktop ,since then it recognises relative paths .But whn I deploy the enite folder structure to the Qliksense server ,btw I have unticked the standard mode setting on the Qliksense server.I also changed the setting in the setting.ini present in the documents folder to 0.

       

      unfortunatly  the reload fails,it just does not recognixe the path variable

       

      Let Qvdpath='../QVD';

       

      the above varibale is not recognized and gives me error when I run it.

       

      I tried restarting the the server after changing the setting,I even tried restarting just  the Qlik engine (control panel) ,but to no avail

       

      followed the thread listed below,but does not work for me

      Re: QlikSense Server legacy mode activation doesn't work

       

      Any suggestions

        • Re: Legacy mode activation on the Qliksense server does not give desired results?
          Levi Turner

          On my end, I've unchecked Standard Mode on the Engine and restarted the Engine (may need to restart all services in your environment). This works fine for me in 2.1.1:

           

          // Write to relative path

          Characters:

          Load Chr(RecNo()+Ord('A')-1) as Alpha, RecNo() as Num autogenerate 26;

           

           

          FOR i = 0 TO NoOfTables()-1

           

           

          LET vTableName = TableName($(i));

          //Writes to C:\

          LET vQVDPath = '..\..\..\..\..\';

           

           

          STORE [$(vTableName)] INTO [$(vQVDPath)\$(vTableName).qvd] (qvd);

           

           

          // //Load from a variable

          LET vQVDPath = '..\..\..\..\..\';

          LOAD * from [$(vQVDPath)\*.qvd] (qvd);