3 Replies Latest reply: Feb 22, 2016 10:42 AM by Magnus Berg RSS

    vG.BasePath not reset in Init.qvs in 1.5.1?

    Frej Sojé-Berggren

      We're having issues moving qvw:s from environment with QDF 1.4.1 to a new Environment with QDF 1.5.1

       

      What happens is that the init.qvs fails on Call GetContainerStructure (vL.GetContainerStructure) however when I look into the log file I see that even before this that the vG.BasePath is still the old one from the previous environment.

       

      When comparing the init.qvs between the two versions I noticed that 1.4.1 has (on line 59)

      // Cleanup, Removing old Path Value
      SET vG.TemplatePath =;
      LET vG.BasePath=;
      

      But in 1.5.1 we only have (on line 52)

      // Cleanup, Removing old Path Value
      SET vG.TemplatePath =;
      

       

      Adding

      LET vG.BasePath=;
      

      to 1.5.1 solves my issue but I'm not really sure it this is the actually cause for my issue.

       

      Has anyone else come across this issue?

        • Re: vG.BasePath not reset in Init.qvs in 1.5.1?
          Magnus Berg

          Hi, I think this have to do with the extended Qlik Sense support, for this we have enhanced the InitLink.qvs functionality, used by both QlikView and Qlik Sense to initiate the framework. Try InitLink.qvs instead of 1.Init.qvs and validate that this works. We will try to find a way so that this problem will not happen in the future, but for now try InitLink.qvs:

          Hope that this helps?

          Best regards

          Magnus

           

          // Basic search for InitLink.qvs

          $(Include=..\..\..\..\InitLink.qvs);

          $(Include=..\..\..\InitLink.qvs);

          $(Include=..\..\InitLink.qvs);

          $(Include=..\InitLink.qvs);

          Exit script when '$(vG.BasePath)'= '';