5 Replies Latest reply: Nov 14, 2017 5:27 AM by Nicander Lauwaars RSS

    NPrinting problem report as JPEG

      Hi,

      nprinting.jpg

      Regularly, JPEG reports generated by NPrinting create a gray image in JPG.

      As if the image capture was made at the time of update

      Have you encountered this problem and how to solve it?

      NPRINTING v16.2.0.0 (SR2)

        • Re: NPrinting problem report as JPEG
          Mike Czerwonky

          Just curious, how are you exporting in a JPG format with NPrinting?  I see all kinds of export formats using a task, but JPG is not one of them.

           

          Does the problem happen with just charts or does it happen with straight tables too?

           

          I have had export issues with images when the user preferences were not set to output.  In the Copying to Clipboard section, you need to have the object type selected that you want to export.    These are not selected by default and they also need to be setup for each user.  So, if you are using a Nprinting service account, you would need to login to your QV desktop client on your Nprinting Server with the service account and set these settings.

           

          User Preferences.PNG

           

          Give that a try and see if it helps

            • Re: NPrinting problem report as JPEG
              Mike Czerwonky

              Any reason why you are choosing Qlikview Entity Reports to send these?

               

              It seems unusual to use Nprinting to distribute a report you created in QV.

               

              Are you posting to a web site and need JPG files?  You can use any of the other templates and generate a PDF that has your images from your charts and it would be pretty easy to setup.  Word or PPT would be the logical formats.


            • Re: NPrinting problem report as JPEG
              Nicander Lauwaars

              I had the same problem. I only encounter this with container objects.

               

              Cause: Nprinting is taking the snapshot while QV is still busy rendering the visuals in the container object.

               

              Poor solution:

              1. Copy the task, remove distribution stuff like a store or an email.

              2. Run this copy first. QlikView has now stored all the visuals you need in the cache.

              3. Run the original task with the distribution in it

              4. You will see that all the visuals are available. No more grey objects.

               

              Even more disappointing solution:

              Don't use container objects. Especially not container in container.