4 Replies Latest reply: Mar 14, 2016 1:17 PM by Herbert Zangarini RSS

    Qlik Sense and port 443

    Petter Grundström

      Hi,

       

      I have tried to install Qlik Sense on a Windows Server 2012 R2 Standard installation but I can't get it working.

       

      When trying to connect to the QMC after the installation I get the error:

      HTTP Error 404. The requested resource is not found.

       

      Googling a bit on this suggests that my port 443 is being used by something else, and I have tried using netstat to find out what is blocking it but from what I can see there is nothing apart from the NT Kernel & System process using it.

       

      Checking the sense installation guide I found this:

      Make sure that port 443 is available for the QPS

      to use, since the port is sometimes used by other software (for example, web servers).


      How do I check that port 443 is available in any other way?


      There is no IIS installed on the system.


      Is there some way around this problem? Enabling HTTP on port 80 without actually opening the QMC?


      Any advice would be appreciated.


      Best regards

      Petter Grundström

        • Re: Qlik Sense and port 443
          Benjamin Schubert

          Hi Petter,

           

          try netstat -no in the CMD Box. There you should find the service which is using the 443 Port and the PID.

          I didn't find a config File where i could change the Ports without the Web UI, too.

          Hope that 'll help.

          Regards

          Benjamin

            • Re: Qlik Sense and port 443
              Petter Grundström

              Hi Benjamin,

               

              Thanks for the answer, sadly it doesn't give any further information:

              Active Connections

                Proto  Local Address          Foreign Address        State           PID

                TCP    127.0.0.1:5939         127.0.0.1:49164        ESTABLISHED     1580

                TCP    127.0.0.1:5939         127.0.0.1:62675        ESTABLISHED     1580

                TCP    127.0.0.1:49164        127.0.0.1:5939         ESTABLISHED     1180

                TCP    127.0.0.1:62675        127.0.0.1:5939         ESTABLISHED     4060

                TCP    192.168.1.3:62314      X.X.X.X:5938      ESTABLISHED     1580

                TCP    192.168.1.3:62671      X.X.X.X:443      ESTABLISHED     7132

                TCP    192.168.1.3:62672      X.X.X.X:443      TIME_WAIT       0

                TCP    192.168.1.3:62673      X.X.X.X:443     ESTABLISHED     7132

                TCP    192.168.1.3:62674      X.X.X.X:5938      ESTABLISHED     1580

               

              PID 7132 is Chrome.exe.

               

              Do you have any other suggestions?

               

              BR

              Petter

                • Re: Qlik Sense and port 443
                  Benjamin Schubert

                  Hi Petter,

                  i'm sorry that it doesn't works. Let's investigate.

                  You installed qlik sense with administrative rights? Sure, cause you read the instruction manual or the videos.

                  After your installation you restarted the qlik sense services or the server? Of cause.

                  The installation provides two icons on your desktop. One for the /hub an one for the /qmc with links similar to

                  https://localhost/qmc and https://localhost/hub.

                  What happens when you try the link for the qmc? Any Errors e.g. certification error in your default browser?

                  ReInstalled the Installation? Any failure messages in the Installation? Central Node Installation was your choice?

                  Regards

                  Benjamin

              • Re: Qlik Sense and port 443
                Herbert Zangarini

                Hi Petter

                 

                You can change the ports manualy.

                 

                You have to access the Postgre database and change this configuration before starting Qlik Sense Services(just the Database service must be running)

                 

                Just take a look at Michael Tarallo comment in this topic Qlik Sense - Proxy Port - Can this be change

                 

                Regards