6 Replies Latest reply: Mar 10, 2016 5:23 AM by Inês Castelhano RSS

    Table or view does not exist

    Inês Castelhano

      Hi folks,

       

      I have a very strange problem. I run a query in SQL (see below) and I get no errors, and the expected result. I run the same query in Qlikview script, and I get the error: "ErrorSource: OraOLEDB, ErrorMsg: ORA-00942: table or view does not exist".

       

      select t1.urg_id, t1.acc_ini_di, t5.hour_dx, t4.acc_det_tr_id, t2.acc_tr_dx, t3.name

      from dwh.tableA t1

      inner join dwh.tableB t4 on(t1.acc_det_tr_id=t4.acc_det_tr_id)

      left join dwh.tableC t2 on (t1.tipo_acc_tr_id=t2.tipo_acc_tr_id)

      left join dwh.tableD t3 on (t4.ACC_VAL5_DX = t3.FUNCI_CD and t3.func_cd='MED')

      left join dwh.tableE t5 on (t5.hour_id= t1.acc_ini_hr)

      where t1.acc_det_tr_id =

          (SELECT max (t5.acc_det_tr_id)

          from tableA t5

          where t5.urg_id=t1.urg_id

          and t5.tipo_acc_tr_id in ('62','56'))

       

      Does anybody have an idea of the cause?

       

      Thanks in advance.

      Ines