23 Replies Latest reply: Jan 23, 2014 11:57 PM by Xena Gillham RSS

    QEMC Access Point URL

      The default Access Point url is: http://localhost/qlikview/index.htm. If I wanted to create a generic url that users could access regardless of the server name how would I go about doing that? The reason I ask is I'd like to have a more generic name for the url so we can have users point to one address regardless of which server we have QlikView on.



        • QEMC Access Point URL
          Bjorn Wedbratt

          Not sure if I follow you, but (as you already know) a web server is by default accessible using the default machine (netbios) name (i.e. http://win2k8 if the machine name is WIN2K8). It is also common that you have a Fully Qualified Name (FQN) registered in DNS for the machine, in the format "machinename.domain" (i.e win2k8.company.com) and in that case users can access the web server using http://win2k8.company.com.

          It's not very uncommon that you have an internal naming convention on your servers that is not very user-friendly (USPRODQVS for a production QVS in the US as an example). In this case you can register alternative DNS-records in your environment, either HOST(A) records or ALIAS(CNAME) records. You can have multiple HOST(A)-records registered on the same IP-address if you want, which is common for example when hosting multiple web sites on the same IIS server:

          USPRODQVS (default HOST(A) record)

          In this example you can reach each of the web sites on the server using:

          http://usprodqvs (default site with default host header=NETBIOS name)
          http://qvs (qvs site with host header=qvs)
          http://portal (a site with host header=portal)

          ALIAS(CNAME) records in DNS will point to already existing HOST(A)-records and can also be used. However, sometimes you need to pay attention to the type of DNS-record being used. Kerberos for example will not utilize the ALIAS(CNAME) records when generating tokens, but the HOST(A) record.

          I suggest you have a chat with your DNS-admin and have him/her register appropriate DNS-records for your environment. If you later install QVS on a new machine (i.e. new IP address), it's easy to simply alter the DNS-record to point to the IP-address for the new machine and the end-users will still access the web site like they're used to.



            • QEMC Access Point URL

              Hey Bjorn,

              Thanks for your reply. Yes, you have part of my question. Our Network admin was going to make all of the DNS changes that you mention above. My question is more around what would I need to change in the QEMC in order for internal users to access the access point from the new FQN. For example, by default our access point has the following URL: http://dcwebb99/qlikview/index.htm. If we change the DNS so the FQN is something like: http://bi-internal.companyname.com what changes would I need to make in the QEMC so when my end users type http://bi-internal.companyname.com that it points to the same Access Point location that http://dcwebb99/qlikview/index.htm . I'm guessing all I'd have to do is rename the URL in the QlikView Web Servers\General area to http://bi-internal.companyname.com . Currently, the name shows up as: http://dcwebb99:4750/qvws.asmx .

              thanks again,


              • QEMC Access Point URL

                I saw the discussion using Alias instead of default server name, but in my case it is not exactly the same issue.
                Even, I try what Bjorn suggested and the result is the same. So I went back to the default configuration.

                "bi-internal.companyname.com" is an ALIAS(CNAME) records in DNS that point to the default server name (DefaultServerName) set during the installation.

                Login to http://bi-internal.companyname.com/qlikview/index.htm : No problem to access the list of QVApps built and distributed.
                The Single-Sign-On works well also with that url.
                But, clicking on a link (My preferred client : IE Plugin) the page is blank and here are the 2 messages I get :

                Line : 2
                Character : 1
                Error : Invalid String (or Invalid Character)
                Code : 0
                url : qvp://DefaultServerName/QVApp.qvw?iis_authenticate={ticket_number}&tunneler=http%3A//bi-internal.companyname.com/scripts/QVSTunnel.dll%3Fhost%3DDefaultServerName

                Line : 1
                Character : 1
                Error : Expected object
                Code : 0
                url : qvp://DefaultServerName/QVApp.qvw?iis_authenticate={ticket_number}&tunneler=http%3A//bi-internal.companyname.com/scripts/QVSTunnel.dll%3Fhost%3DDefaultServerName

                But as soon as I put the "http://DefaultServerName" in the trusted sites of IE it works well.

                My issue is that, in my company, Host file is prohibited on end users machines; and trusted sites neither allowed; only the sites ending by "companyname.com" is to be used and are included in "Intranet Local" zone (in Security of IE Internet Options).

                Could you help me fixing this issue ?


                  • QEMC Access Point URL
                    YVES BLAKE

                    In "Program files\QlikView\Server\QVClients\QVPlugIn" :
                    - rename opendoc.htm as opendoc.bck
                    - then rename opendoc_fix.htm as opendoc.htm

                    This will solve security issues regarding frameset under IE.

                      • QEMC Access Point URL

                        I got some understanding on the redirecting the pages..But here is my requirement.

                        I have a 2 Cases

                        1) When the user is not having installed the Qlugin Plugin and he logged in, in this case what to show the customised message like "Your the First Time user want to install the qlikview Y/N.If Yes then the QlikView Installation has to taken place or N Ignore the action.

                        2) If the user is using the AZAX and is not a Authorised one then It's popping up for user id and password.This should be replaced with Proper message like ' NOT A AUTHORISED USER.Please contact so and so person'.

                        Can anyone help me in understanding 'What changes I have to do & where I have to do ....