2 Replies Latest reply: Mar 18, 2016 4:19 AM by Alexander Kommeter RSS

    Datumsformat Legende formatieren

    Alexander Kommeter

      Hallo zusammen,

      ich bräuchte eure Unterstützung bei der Formatierung bzw. anderen Darstellung meiner Legende.

      Ich erstelle eine Auswertung über den Volumenverlauf in unserem Helpdesk.

      Dabei wird der Zeitstempel leider sehr unleserlich angezeigt. Mir ist klar das er so angezeigt wird, wie wir ihn aus der Datenbank holen.

      Und genau so wird er geliefert (YYYYMMDDHHMMSS).

      Ich habe nun versucht die Legende zu begrenzen, leider begrenzt er zuerst von hinten...Somit wird aus 201603070715-->2016...

      Das Funktioniert also auch nicht.

      Mein Zielbild wäre, dass die Uhrzeiten angezeigt werden und der Tag zusammengefasst abgebildet ist. Analog dem hier (Jahreszahlen=Uhrzeit /Monat=Datum):

      Das Datumsformat über Eigenschaften/Zahlen anzupassen bringt mich leider auch nicht zum gewünschten Format.

      Ich habe Qlikview bisher eher recht "oberflächlich" verwendet und bin auch nicht der Programmiercrack.

      Ich hoffe jemand von euch kann mir daher weiterhelfen!!!

      Vielen Dank.

        • Re: Datumsformat Legende formatieren
          Marco Wedel

          Hallo Alexander,

           

          in short:

           

          try to load your timestamp as real/dual timestamp and derive your date field from it like

           

          LOAD *,
                    DayName(/yourtimestamp) as yourdate;
          LOAD Timestamp#(yourtimestamp,'YYYYMMDDhhmmss') as yourtimestamp
          FROM ...
          

           

          you could combine this solution with a master calendar and create some drill down dimension to be able to drill from longer periods into daily details if necessary.

           

          Best you posted some sample data/application to demonstrate.

           

          hope this helps

           

          Gruß

           

          Marco

            • Re: Datumsformat Legende formatieren
              Alexander Kommeter

              Hi Marco,

              I have changed current Load that I am using and added this criterias.

              It works now :-)

               

              Load *,

               

              DayName(CONTACT_START_DATE) as CONTACT_START_DATE,

               

              WeekDay(CONTACT_START_DATE) as CONTACT_START_DATE_WEEKDAY,

              YEAR(CONTACT_START_DATE)&'_'&num(month(CONTACT_START_DATE),00) as CONTACT_START_DATE_YEAR_MONTH,

              YEAR(CONTACT_START_DATE)&'_'&week(CONTACT_START_DATE) as CONTACT_START_DATE_YEAR_WEEK,

              Time(class(Maketime(hour(CONTACT_START_DATE),minute(CONTACT_START_DATE)), 1/24)) as CONTACT_START_DATE_TimeBucket_60,

              Time(class(Maketime(hour(CONTACT_START_DATE),minute(CONTACT_START_DATE)), .5/24)) as CONTACT_START_DATE_TimeBucket_30,

              Time(class(Maketime(hour(CONTACT_START_DATE),minute(CONTACT_START_DATE)), .25/24)) as CONTACT_START_DATE_TimeBucket_15