12 Replies Latest reply: Feb 15, 2017 6:33 AM by Bi Tech Support RSS

    Why isnt my app saving after reloading data?

    Paul Tomeo

      Hey everyone,

       

      I ran into a really odd issue today. I tried updating my data for one of the Apps that I have created and when I go to the Load Editor and Click on the Load data button my Qlik sense just hangs. It goes through the normal loading process but at the end when it does to save the app it hangs up. But the odd thing is it doesn't freeze, I had the load clock up to about an hour trying to save this app, and finally had to do a hard close out of Qlik for it to respond.

       

      Typically (yesterday) this process took me no longer than 60 seconds.

       

      All of the files are stored locally so it does not seem to be an networking issue.

       

      I am now unable to refresh any of my apps with new data so any help is greatly appreciated!

       

      And I apologize if this is not the correct place for this question, I tried to logging a case through the support tracker page but I guess I don't have the proper permission to do so.

       

      Thanks again for your guidance!

        • Re: Why isnt my app saving after reloading data?
          Ralf Narfeldt

          Is this on Qlik Sense Desktop or a server installation?

            • Re: Why isnt my app saving after reloading data?
              Paul Tomeo

              I am using Qlik Sense. I tried letting the app save over night but still didn't get me anywhere. 15 hours and the app still wouldn't save. Saving App... issue.jpg

               

              The odd thing it doesn't seem to be an issue with the data, as I have another app that uses the same data sets and it loads and saves as normal. But this app doesn't seem to want to work.

               

              I have also tried just saving the app after making a change to the size of a graph, but this also doesn't work. It never saves and will give me the message "There are unsaved changes in this app. If you refresh or close this page, your changes will be lost", if I go to close the app.

            • Re: Why isnt my app saving after reloading data?
              Paul Tomeo

              So I have figured out a work around to this issue but the bug still is causing me issues, so if anyone has any thoughts or can help me escalate this to the support team it would be greatly appreciated.

               

              I don't know what caused the issue initially. But the problem is currently presenting itself when I try to refresh my data with updated data, the Data load process gets stuck when trying to save the App. Note that is does not freeze as the elapsed time continues to count, but this process never completes.

               

              The only way to resolve this issue is to close the program while it is still trying to save, and restart my computer. This then allows me to reopen the App, but in order to get the App to refresh the data I have to open up the Load scripts that I have created and copy the script. I then delete the script and create a new script where I just paste in the old script text. Now I am able to load the data and save the App as desired.

               

              This solution is extremely frustrating to have to do this every time I want to refresh my data with current information.

               

              Please help!!

                • Re: Why isnt my app saving after reloading data?
                  Michael Smith

                  As means of a quick aside, you don't need to close down your computer in order to re-open the app.  Simply close Qlik Sense and then go to task manager.  Now, even though you've closed Qlik Sense completely, you'll notice that the QlikSense.exe is still running in task manager.  If you end this process you'll be able to open up your app without having to close your computer.  This doesn't however resolve the failure to save issue...

                • Re: Why isnt my app saving after reloading data?
                  Grant McGough

                  I am having a similar problem but mine typically cuts off and says internal error after 20 minutes. I can exit out and close out of the systems with the task manager and still get the app back, but the data is out of date and even if I restart and copy, delete, and paste it does the same thing.

                   

                  If there is any other to get it to upload new data that would be great!

                  • Re: Why isnt my app saving after reloading data?
                    Michael Smith

                    Solved! Admittedly, I have no idea why this worked, but it did so I'll go with it.

                     

                    I was having the same issue with respect to the app running through the reload and then getting stuck in the 'saving app..' stage.  Instead of having to rewrite the code as has been suggested by other users as a work around, all that I needed to do was to exit out of Qlik Sense, end the QlikSense.exe on task managed, as mentioned above, locate the .qvf in question and then create a copy of it. I didn't even need to open the copy.  I was then able to open and reload the original file without experiencing the same issue.

                     

                    It is an odd error and something Qlik really needs to resolve in future releases.

                    • Re: Why isnt my app saving after reloading data?
                      Bi Tech Support

                      seems it's a bug, Just duplicate the app and reload it. I hope Qlik Sense Support Team will fix this soon.

                       

                      Kerem