2 Replies Latest reply: Jan 10, 2011 8:46 PM by Steve Rimar RSS

    Sharepoint permissions

      I read through the other post on this but I was unable to find an answer.

       

      I would like to read data from an xls file stored on our shareponit site. I am able to accomplish when developing but when I run the job through publisher it fails. I am guessing it is a permissions issue. I am guessing the account running the QVS and QVP services needs permissions to sharepoint? We have tried a few different combinations but the job is still failing. Does any one have any idea of what permissions need granted to who?

      We are running 8.5 on a windows 2003 64 bit server, webclient service is installed and started.

       

      Thank you

        • Sharepoint permissions

          When reading a share or any other path located outside the machine running Publisher, the account running Execution Service needs read and modify rights to be able to access it.

            • Sharepoint permissions

              We have the same exact problem in our environment and all QlikView services run under a system account which has full permissions to the SharePoint location. We tried this with both SharePoint 2007 and 2010. We also did a trace on the QlikView server and when the Publisher tries to reload the document it gets a 401 when trying to execute an HTTP OPTIONS command to our SharePoint server.

              Manually logging on to the server as the service account that runs publisher and navigating to the SharePoint UNC path provides an authentication prompt. After authenticating with the service account and password we're able to open the source file we're trying to reload from.

              Any other ideas? I'm going to try to submit this to support but it may take a while to get it resolved.