5 Replies Latest reply: Dec 30, 2010 9:10 AM by tylerwaterfall RSS

    EDX Trigger. Error: msxml3.dll: Access denied

    Miguel �ngel Garc�a

      Hello,

      I'm using the attached vbs to trigger a task on QV Server 9. I did a test on my laptop, with a local QV Server, via command line and the task was executed. Great!

      BUT then I tried to do the exact same thing with an alternate user on the same laptop and member of both, Administrators and QlikView Administrators, groups (So it has the same permissions) and the task was not executed. I got an error of msxml3.dll: Access denied for line 71 that issues the following command:

      xmlhttp.send requestData

      I just left everything running for the first user and then "Switched" user. If I tried to log off from the first user and then log on on the second I got an error of File Not Found (not the vbs but some of the files it uses).

      I do have access to the local server. Also, I'm using Windows 7 and cannot change the permissions for that DLL file, which is found under the Systme32 folder. All the options to set permissions are grayed out when I click on Edit (Permissions) or Advanced... However, I dont think it is a matter of FILE permissions, because as I said, both users have Administrator priviliges and both have Read and Execute Permissions on that DLL.

      Another thing I tried was to change Internet Explorer options, add the site to Trusted Sites and enable "Access Data Sources across domains" and I believe all of the ActiveX permissions.

      What can I be doing wrong? Any idea is appreciated.

      PS: The script was originally posted by Rob Wunderlich on this forum thread:

      http://community.qlik.com/forums/p/28641/109938.aspx

       

      Sorry, could not attach the file, here is a direct link: http://community.qlik.com/cfs-file.ashx/__key/CommunityServer.Components.PostAttachments/00.00.11.02.76/RequestEdxV9.vbs