4 Replies Latest reply: Apr 17, 2016 11:40 PM by Shyam Sreeramula RSS

    Session Collaboration on Distributed document

    Shyam Sreeramula

      Hi Experts,

       

      I have set Session Collaboration feature on a document which is distributed by publisher.

      The folder to which the publisher distributes the document is in other server and where QlikView server is installed.

      But, the publisher is installed on the different server.

       

      I have placed all my documents on Publisher server and created a distribute task to distribute the document to QlikView Server folder to view in Access Point. Everything working good but after the document is reloaded in schedule and distributed I lose the Session collaboration feature.

       

      Can I know what I am missing?

       

      Also if someone could help me what is the format/syntax i should use in the document when the server and publisher are on different servers?

       

      Regards,

      Shyam.

        • Re: Session Collaboration on Distributed document
          Staffan Johansson

          You have to use correct path in Your Source document, Like this:

           

          LOAD *
          FROM
          [\\SERVERNAME\QV_Publisher\Source\QVDFiles\file.qvd]
          (
          qvd);

           

          Even if the folders are on the same server and should be Distributed to the folder "behind", like this:

          Publisher.PNG

           

          the services that runs Publisher (QDS) is installed on the other server and need to know the exact path.

           

          Session Collabration is set on each Distributed document and one general setting on server.

           

          What feature is lost after distribution?

           

          • Re: Session Collaboration on Distributed document
            Peter Cammaert

            Do you distribute your document to a folder or to a QlikView server?

              • Re: Session Collaboration on Distributed document
                Peter Cammaert

                Nevermind.

                 

                Upon rereading your OP, I get the impression that you manually set Session Collaboration for this document in QMC->Documents->User Documents->Server->Availability. This is just a guess (not clear from your post) so correct me if I'm wrong.

                 

                The QMC->User Documents tab allows you to set many document options straightaway from the Management Console. However this is just a manual and possibly temporary modification. Why? Because the Publisher can set almost all of the same document options by simply executing the corresponding document task. And the Publisher always overrides what you have set in the User Documents tab.

                 

                Check out QMC->Documents->Source Documents->Select your document and open the task->Server->Availability->User privileges, and compare this to the settings in QMC->Documents->User Documents->Select your published document->Server->Availability->User Privileges. Do they look similar?

                 

                Make sure that the task sets the correct options on distribution, and you're fine. Tasks have a final say...

                 

                Best,

                 

                Peter

              • Re: Session Collaboration on Distributed document
                Shyam Sreeramula

                Hi Staffan, Peter,

                 

                Sorry for the delayed response. I was occupied with a few stuff and couldn't respond.

                I have made changes a bit.

                 

                As Staffan suggested, I have used \\server\folder1\folder2\folder3 paths in my QVD generator, Data Model and the Dashboard. Now the issue seems to be resolved.

                 

                Earlier I had put the documents in Publisher Server VM and distributed to the QlikView server. I had set the session collaboration on the distributed document and hence I believe I was losing the option everytime it is been overwritten by the newly distributed copy.

                 

                Thanks a lot for your suggestions. They helped me learn a lot.

                 

                Thanks for your patience too .

                 

                Sincerely,

                shyam.