5 Replies Latest reply: Apr 14, 2016 4:24 AM by Friedrich Hofmann RSS

    Very strange problem with QlikView_apps on the server ...

    Friedrich Hofmann

      Hi,

       

      we have an entire cascade of QlikView_apps running one after another on our company server. First in line is a primary data_load_script getting the data from our database and storing it in qvd files, doing some edits on the data at the same time.

      The strange thing is:

      - There is a STORE command for nearly every table in there.

      - These used to look like >> STORE mytable INTO QVD\mytable.qvd << (only a relative path was specified, not the full path)

      - There is a checkbox "relative paths", this was always ticked.

      - A while ago I switched this to using filepath_variables in which the fully qualified path is stored in a txt file. I tested it and it worked fine.

         I didn't pay attention to that checkbox, I guess I left it ticked.

      - Strangely, this went well for quite a while - but every now and then we have a problem where the script suddenly breaks when storing

         some table or other and it just says "General script error".

      => I removed the path_variable as I thought, maybe this was the error, but I replaced it with the fully qualified path - and the error still

           persisted.

      => Later, a colleague of mine replaced it with the relative path that used to be there, and it worked again.

       

      I don't know why this happens - and why it seemingly does not happen every time, but only now and then ...

      Can you tell me something about this? Is there some feature which is a bit "wobbly"?

       

      Thanks a lot!

      Best regards,

       

      DataNibbler