9 Replies Latest reply: Apr 29, 2016 9:40 AM by Mike Czerwonky RSS

    Avoid pixelation

    Sifat Rahman

      Hi all,

       

      How do I avoid pixelation when inserting an object (e.g. straight table) as an image on a PixelPerfect report? It seems even with Sizing = "Normal", it still becomes pixelated when the report is generated in PDF. Any ideas? Thanks.

        • Re: Avoid pixelation
          Daniel Jenkins

          Hi Sifat,

           

          Images used will have their resolution fixed the same as if they were exported from your QlikView document. To get a truly pixel perfect table (vector graphics) you will need to create it natively in the PixelPerfect report editor. Here is a screenshot of this report at 800%.

           

          More tutorials here: QlikView NPrinting 16 Tutorials - PixelPerfect Reports

           

          HTH - Daniel.

          • Re: Avoid pixelation
            Mike Czerwonky

            Hi Sifat,

             

            You can use clipboard zoom to improve the quality of images as they leave Qlikview.   Here is a link to review to see if it might help your situation.   Native export from QV is 100 dpi.  I have found that 400 dpi works well.

             

            Improving Image Quality Export using Clipboard Zoom

              • Re: Avoid pixelation
                Sifat Rahman

                Hi lubicz99, I tried this but the image just becomes larger, not sharper, when I set clipboard zoom to either 400 or 800. I'm using Qlikview Desktop SR11. I'm a bit baffled because doing a Print Preview on a report on QV Desktop produces a perfect image, but doing preview on NPrinting Designer creates pixelation. I also tried Auto Size and Normal for sizing in NPrinting.

                  • Re: Avoid pixelation
                    Mike Czerwonky

                    I don't typically use the Pixel Perfect template.  What font are you using in your app?  Some fonts are designed optimally for printing and some for web sites.

                     

                    We are using Arial in 8-12 pt range for most of our objects.

                     

                    The purpose of clipboard zoom is to improve your quality by 400%, however when you bring the object into your template you need to use the format object and change the size relatively or you will lose the quality.   I try to design my objects in QV exactly the same size they will appear in my report without auto sizing.  Say is it 600 x 300.  When you get to the Nprinting side, the object will be 2400 x 1200.  You go to format and size and relative and adjust either your width or height back to the desired size and your object should maintain its quality.

                     

                    If you are using Version 17, I can not speak for how it interacts with Clipboard Zoom.  I am using NP 16 and QV 11 SR9

                     

                    You could make a new nprinting template in word or power point and bring your test object in and see if it loses its quality in either of those in preview mode.

                     

                    Hope that moves you forward.

                      • Re: Avoid pixelation
                        Sifat Rahman

                        Thanks I'll try this now. What do you use if not Pixel Perfect?

                          • Re: Avoid pixelation
                            Mike Czerwonky

                            I have not had many requests for banded reports, so we typically use Excel and Power Point for generating output as I find it is the easiest to setup.  Both of these will allow you to store your output as PDF, although I have found that their is a page limitation of 60-70 before it runs into conversion issues and runs out of memory.  Again, all of my output is with v 16, so I can speak for the new version.  I am however, going to be at Qonnecfions this week and will have an extended conversation with Aran and the rest of the Nprinting staff.

                             


                              • Re: Avoid pixelation
                                Sifat Rahman

                                lubicz99 I figured out why it wasn't working. I have NPrinting 16 (downgraded from 17 because 17 has major showstopper bugs which I have raised to Qlik UK), and QV SR11. Along with the clipboard zoom, you MUST select the Include Caption and Border Options, which you have mentioned in the comments section under Improving Image Quality Export using Clipboard Zoom

                                 

                                Without this second step, it simply won't work. However, there is a third step:

                                 

                                The third step is to set your picture Sizing on NPrinting 16 to "Zoom". I can find no solution RE: adjusting size, e.g. 400 x 600; it can be whatever size you want on NPrinting Designer 16 so long as the "Zoom"  is set, and it will come out with a perfection resolution irrespective of picture size on the report. This means you are free to size it any way you like!

                                 

                                I'm very happy with the PixelPerfect report now because you can set headers and footers and don't need to deal with levels, etc. since image quality is solved with these 3 steps. Thanks for your help!

                                  • Re: Avoid pixelation
                                    Mike Czerwonky

                                    Glad you were able to come to a solution.  Yes part 2 was discovered after original post.  Your resolution of an object is set in you caption properties in QV.  I translate 100 pixels to 1 inch.  So, setting your width and height of your object gets you the default output to Norinting before Zoom.

                                     

                                    Glad I could be if help

                              • Re: Avoid pixelation
                                Sifat Rahman

                                Thanks - where can I find the resolution though? I'm not able to figure out how big the object is in QV, e.g. 600 x 300.