4 Replies Latest reply: May 12, 2016 8:18 AM by Rodolfo Barbosa RSS

    Consulta retorna valores no PL/SQL mas não no Qlikview

    Rodolfo Barbosa

      Boa noite,

      Tudo bem pessoal?

      Tenho uma consulta que no meu PL/SQL Retorna Valores, porém no Qlikview não...

       

      O que poe estar acontecendo?

       

      Segue o script:

       

      PAC_90:
      SQL
      select b1.ano as ano_pac_90, b1.mes as mes_pac_90, count(*) qtd_pac90
        from (select a.cd_mot_alt,
                     a.cd_multi_empresa,
                     trunc(a.dt_atendimento) dt_ini,
                     trunc(nvl(a.dt_alta, sysdate)) dt_fim,
                     (trunc(nvl(a.dt_alta, sysdate)) - trunc(a.dt_atendimento)) dias
                from tb_atendime a
               where a.cd_multi_empresa = 4
                 and a.tp_atendimento = 'I') a1,
             (select extract(year from add_months('01/01/2010', level - 1)) ano,
                     extract(month from add_months('01/01/2010', level - 1)) mes,
                     to_char(add_months('01/01/2010', level - 1), 'yyyymm') anomes
                from dual
              connect by level <=
                         abs(round(months_between('01/01/2010', '31/12/2100')))) b1
       where a1.dias >= 90
         and b1.anomes between to_char(a1.dt_ini + 90, 'yyyymm') and
             to_char(a1.dt_fim, 'yyyymm')
       group by b1.ano, b1.mes
       order by b1.ano, b1.mes;
      

       

      E os prints dos retornos...

      Qlik

      print 0.png

      PL

      prin return.png