10 Replies Latest reply: Nov 22, 2010 10:58 AM by Miguel Angel Baeyens de Arce RSS

    How to setup to use Ajax zfc

    Goran Korsgren

      We have just set up a new Qlikview Server 9.0.7646.9 and are trying to get ajax zfc to work.

      We are running to the QV Web server

      We have created a simple "Hello World!" type qv application, and are trying to connect to it,
      but there is a problem when the webpage calls QvsViewClient.asp,
      we just get a blank page and not the qv document we expects
      this is from the
      QV Web server log when we call http://localhost/Demo/helloqv_ajax/default.htm:


      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/Demo/helloqv_ajax/default.htm
      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/QvAjaxZfc/htc/modal/modal.css
      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/QvAjaxZfc/htc/QvAjax.js
      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/QvAjaxZfc/htc/QvAjaxBaseMgr.js
      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/QvAjaxZfc/htc/QvAjaxScan.js
      2010-11-17 11:02:57.4723584 Information Request received [GET]: http://localhost/Demo/helloqv_ajax/PageModifications.js
      2010-11-17 11:02:57.5036092 Information Request received [GET]: http://localhost/QvAjaxZfc/htc/QvAjaxModal.js
      2010-11-17 11:02:57.5192346 Information Request received [POST]: http://localhost/Demo/helloqv_ajax/QvsViewClient.asp?mark=&view=helloqv.qvw&platform=browser.MSIE 8.0
      2010-11-17 11:02:57.5192346 Warning Response aborted, path=/Demo/helloqv_ajax/QvsViewClient.asp
      2010-11-17 11:02:57.5192346 Information Request received [POST]: http://localhost/Demo/helloqv_ajax/QvsViewClient.asp?mark=&view=helloqv.qvw&platform=browser.MSIE 8.0
      2010-11-17 11:02:57.5192346 Warning Response aborted, path=/Demo/helloqv_ajax/QvsViewClient.asp



      So we get response from the generated default.htm-page but there is an error when QvsViewClient.asp is called,
      there is no QvsViewClient.asp at the Path specified in the log file,
      QvsViewClient.asp resides in C:\Program Files\QlikView\Server\QvClients\QvAjaxZfc

      What is missing or wrong in our setup?

      error loading image

       

      error loading image

       

      error loading image