3 Replies Latest reply: Nov 22, 2010 8:00 AM by blackryu RSS

    OLEDB on QVS

      Hi,

      I am trying to connect to my Oracle 11g database using OLEDB. I am using one qlikview file to load my data into QVD files, and then using another to read from the QVDs into a live app. I have setup the connection string on the first file with a stored password and it works fine from my Windows 7 desktop.

      When I copy the file to the server (Windows 2008) documents folder, the reload never happens. It is scheduled but always fails. I have installed the required drivers on the server and can establish test connection using ODBC.

      I don't know how to test an OLEDB connection without using Qlikview so I tried to install Qlikview 9 on the server to see if I could run a reload from there, with the connection string, rather than using the publisher schedule. However, When I open the required qlikview file the "reload" and "edit script" options are either grayed out or not there.

      Does anyone have any idea how to fix this, or at least a description of how to troubleshoot this. I have tried enabling logging, but the log files don't seem to mention anything about why the reload fails.

      Thanks

        • OLEDB on QVS

          Hi,

          I think in OLEDB also you will find the test connection button.

          Are you able to view your tables after clicking on the connect button in the edit script either in OLEDB or ODBC ?

          Regards,

          Ravi

           

            • OLEDB on QVS

              Hi Ravi,

              On my Windows 7 Desktop I can see all of the tables etc

              On the server,, I am able to create and ODBC DSN using Windows that successfully connects, that is how I was checking to see if the drivers were correct. I don't know how to recreate this for OLEDB.

              However, When I tried to load the Qlikview document from the QV instalation on the Server, the "View Script" selection is not there and the "Reload" is disabled. This means I can't test whether the connection string within this document actually works when it is on the server.

               

              Thanks for the reply,

              Peter

            • OLEDB on QVS

              I have figured out why I couldn't reload from the Qlikview App. The user I had logged onto on the server did not have a named license, only the normal access license.

              I can now reload from the Qlikview application without any problems, but when I try to apply the schedule the reload still fails without any other information