5 Replies Latest reply: Jan 3, 2012 5:21 AM by Graeme Smith RSS

    Qlikview 10 IR Server problem

    Sergio Martin Alvarez

      Greetings from Argentina, i have a server running Windows 2003 server R2 and Qlikview Server 10 IR. I did all the installation with no problems, but when i restart and check the services, the only one that runs ok is Qlikview server. The Web Server, Reload Engine and the Directory Service Connector are disconnected, as the next picture shows:

      error loading image

      The user used (qlikadmin) to install belongs to the groups administrators of the server and qlikiew administrator.

      error loading image

      error loading image

      Besides this, the web server is working fine, because i can see the access point and open the applications without any problem. I've verified the logs and they are all right except for one, the Directory service connector. It has several errors:

      12/6/2010 19:01:25.1224946 Information Shutdown

      12/6/2010 19:01:26.7647996 Information Initializing root

      12/6/2010 19:01:26.7960816 Information Loading DSP plugins

      12/6/2010 19:01:26.8273636 Information Scanning directory C:\Program Files\QlikView\Directory Service Connector\DSPlugins

      12/6/2010 19:01:26.8273636 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\ActiveDirectory.dll

      12/6/2010 19:01:26.8430046 Information Loaded plugin Active Directory

      12/6/2010 19:01:26.8430046 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\CustomDirectory.dll

      12/6/2010 19:01:26.9212096 Information Loaded plugin Custom Directory

      12/6/2010 19:01:26.9368506 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\Database.dll

      12/6/2010 19:01:26.9524916 Information Loaded plugin Configurable ODBC

      12/6/2010 19:01:26.9524916 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\GenericLDAP.dll

      12/6/2010 19:01:26.9681326 Information Loaded plugin Configurable LDAP

      12/6/2010 19:01:26.9681326 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\LocalDirectory.dll

      12/6/2010 19:01:26.9681326 Information Loaded plugin Local Directory

      12/6/2010 19:01:26.9681326 Information Loading file C:\Program Files\QlikView\Directory Service Connector\DSPlugins\WindowsNT.dll

      12/6/2010 19:01:26.9837736 Information Loaded plugin Windows NT

      12/6/2010 19:01:26.9837736 Information Loaded 6 plugins

      12/6/2010 19:01:26.9837736 Information Initializing service

      12/6/2010 19:01:27.0463376 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0463376 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\2369fcf9-9e3c-43d2-a7d9-34d04338e5ed: The given key was not present in the dictionary.

      12/6/2010 19:01:27.0619786 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0619786 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\45a230ef-af5d-406d-a3e0-f34b01b92ac5: The given key was not present in the dictionary.

      12/6/2010 19:01:27.0619786 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0619786 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\6c329038-d9f5-4843-9c39-a6b943e00afa: The given key was not present in the dictionary.

      12/6/2010 19:01:27.0619786 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0776196 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\8c6ed965-b250-41db-8efa-c6e3d0e83dec: The given key was not present in the dictionary.

      12/6/2010 19:01:27.0776196 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0776196 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\e46d2c80-c404-4ce7-93a5-2e9022332b96: The given key was not present in the dictionary.

      12/6/2010 19:01:27.0776196 Error Exception in SetupResource Exception=System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

      at System.ThrowHelper.ThrowKeyNotFoundException()

      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

      at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

      12/6/2010 19:01:27.0932606 Error Parse error setting up resource C:\Documents and Settings\All Users\Application Data\QlikTech\DirectoryServiceConnector\Resources\f367898b-4082-4798-ae9d-6a2db9ab8cb4: The given key was not present in the dictionary.

      12/6/2010 19:01:27.2496706 Information (ActiveDirectory.ActiveDirectoryProvider) No ncname supplied, so we use the root domain

      12/6/2010 19:01:27.3591576 Information (ActiveDirectory.ActiveDirectoryProvider) Domain 'LDAP://errepar.com/DC=errepar,DC=com' looked up

      12/6/2010 19:01:27.4686446 Information Starting webservice at port 4730

      12/6/2010 19:01:27.4842856 Information Initializing done

      12/6/2010 19:01:27.5155676 Information Initializing system webserver

      12/6/2010 19:01:27.5155676 Information Webserver security set to: Ntlm

      12/6/2010 19:01:27.5155676 Information Authorization groupname: QlikView Administrators

      i think the installation its not working well, but i re-installed several times with the same result. I don`t know what to do now. Since now, every help, response and information will be very gratefull.

      Sergio

        • Qlikview 10 IR Server problem
          Sergio Martin Alvarez

          Well, after few hours reading the error on the log and looking on internet, i realised that the problem was the .NET Framework, i had .NET 3.5 without SP but with a lot of old updates, so it wasn´t working well with the QVS. The solution for me was:

          1) I uninstalled .NET it using the .net cleanup utility of Microsoft (it`s installed with the .net)

          2) Then i uninstalled the QVS (and i deleted the registry entrances and the folders from Program FIles and Document and settings\All Users\Application Data).

          3) Restart

          4) Install .NET Framework 3.5 with all SP and updates. Restart

          5) Install Qlikview 10 Server. Restart

          6) Apply the licences and configure the QVS 10. Enjoy!

          Greetings to all!!

          • Qlikview 10 IR Server problem

            I tryed do the same.. but didn't work.  =[

             

            Now, I'm using .NET 4.0 and looking for logs.. I found the some problem when to started DirectoryServiceConnector:

             

            10/08/2011 13:19:48.4740598 Information Initializing service

            10/08/2011 13:19:48.5208598 Error Exception in SetupResource  Exception=System.Collections.Generic.KeyNotFoundException: A chave fornecida não estava presente no dicionário.

               em System.ThrowHelper.ThrowKeyNotFoundException()

               em System.Collections.Generic.Dictionary`2.get_Item(TKey key)

               em DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

            10/08/2011 13:19:48.5364599 Error Parse error setting up resource C:\ProgramData\QlikTech\DirectoryServiceConnector\Resources\1980b522-976f-4f75-8a5a-b37b0b6ead7f: A chave fornecida não estava presente no dicionário.

             

            What have I do!

            • Qlikview 10 IR Server problem
              Graeme Smith

              Hi, I had the same symptoms, with a different root cause.  For me, this issue was resolved by amending the proxy settings in IE on the server.  Looks like the HTTP requests from the QEMC to the relevant services (QDS, QMS, etc) were being directed out via (and being blocked by) our firewall.  Bypassing the proxy for local addresses did the trick. 

               

              IE -> Tools -> Internet Options -> Connections -> LAN Settings -> Bypass Proxy Server for Local Addresses

               

              Hopefully helps someone else facing the same symptoms...