1 Reply Latest reply: May 25, 2016 4:45 PM by Alejandro Fernandez RSS

    Why my Dashboard not utilising 100% CPU for calculating complex Expressions

    Manoranjan Ayyaswamy

      I have a big QV Dashboard application of size more than 3 GB. I have optimized the Data model several times (even reviewed with experts and implemented what they have suggested). It has huge Fact table with close to 185 million records, and few heavy expressions to the likes of AGGR, COUNT DISTINCT , Complex Set Analysis with multiple layers of Set modifiers. This is hosted in a server that has 32 Cores and 756 GB RAM.

       

      I would expect my Dashboard to use maximum capacity of my hardware and hence reduce the response time. But it does not. CPU utilization goes only up to 35% but the Response time is more than 10 seconds.

       

      I have set the Hyper Threading to Disabled already. How to proceed further to make the QVS use 100% CPU for faster response time.

        • Re: Why my Dashboard not utilising 100% CPU for calculating complex Expressions
          Alejandro Fernandez

          Is your Server on the hardware white list?

          There are a few tips recommended by Qlik:

           

          A general guideline on performance is that, larger QlikView applications perform better on a smaller number of faster CPU cores with a faster memory bus can perform better than a larger number of slower CPU cores.


          The following settings are recommended to set in BIOS for QlikView Server:

          • Hyper-threading - Disabled
          • Power Management (Power Profile) - Max Performance (BIOS and Windows Setting)
          • Node Interleaving - Enabled
          • NUMA - Disabled. If NUMA can't be disabled (common in IBM servers) - see below.
          • Hardware pre-fetch - Enabled, however there are diverse results of this and one should verify per setup

          Intel Turbo Boost Technology - Enabled

           

          Have you tried those?

           

          Cheers