4 Replies Latest reply: Dec 27, 2010 9:49 AM by Rob Cleek RSS

    Post QV9 Upgrade Performance has eroded

    Rob Cleek

      We upgraded our environment last weekend from 8.5 to 9.6. In our previous configuration we had two standalone servers, both having 4 quad cores and 128 gigs of RAM. In 8.5, our average query came back in roughly 5-10 seconds. Our times now hover around 30 - 60 seconds.

      During the upgrade, we migrated to Windows 2008 SR2 server, and implemented a clustered environment. I now have a mutany on my hands from the business and I'm running out of ideas.

      I set the power plan on the OS to performance as recommended by post http://community.qlik.com/forums/t/33509.aspx and I plan to disable hyperthreading tomorrow night.

      I've also clocked the speed on the Access Point versus the thick client, and notice the times are better when using the client, however, I really don't want to roll that out to the business again (but I will if I have too)

      I'm wondering if anyone else is/has expereinced this, and have any suggestions on how to make it better.

      Thanks in advance, Rob

        • Post QV9 Upgrade Performance has eroded

          Hi,

          Ouch... There were too many changes in one go: QlikView version upgrade, QV clustering, and Windows upgrade.

          You mention also hyperthreading: did you switch hardware too? In that lucky case, just power back the old servers and than take your time to separate what went wrong.

          Regarding rollback on same hardware:

           

          • Having same issue with upgrade from 2003 to 2008. However, rolling OS installation is very time consuming . And you depend on a lot of people to approve and implement.
          • Clustered AccessPoint is slow in QV9. De-clustering QV is easy; users were used having two standalone machines. Or see here for a workaround with static HTML: accesspoint: http://community.qlik.com/media/p/148199.aspx
          • QVS is comparable in speed in both versions. Reload tasks are multi-threaded in QV 9, so running more CPU intensive reloads same time will use more CPU. This is especially noticeable if QVS and Publisher are in same hardware.


          -Alex

            • Post QV9 Upgrade Performance has eroded
              Rob Cleek

              It's the same hardware. We did an upgrade on the OS, then upgraded the QV software. I read somewhere that Windows 2008 SR2 was introducing some turbo processing which could impeded performance on optimized software packages like QV. That's why I was thinking that turning off hyperthreading would help (or at least it's something to try that I thought had merit).

                • Post QV9 Upgrade Performance has eroded

                  Hyperthreading has to be OFF regardless of windows 2003 / 2008.

                    • Post QV9 Upgrade Performance has eroded
                      Rob Cleek

                      Looks like hyperthreading was off by default on both servers, so that's good. I enabled the node-interleave and disabled the hardware pre-fetch on both servers based on recommendations from QV Support. It did speed up the system a little bit, but not overwhelming.

                      Here's a list of things I've tried:

                      • diabled performance logging on the QEMC
                      • BIOS changes mentioned above
                      • modified the config file to have our cluster go from 'Random' to 'DocumentLoad'
                      • Modified the Max Memory configurations on the QEMC > Performance tab and doubled all the values
                      • Made data modeling changes to gain a few seconds here and there.
                      • changed the QVSTimeout flag from 60 seconds to 600 seconds
                      • disabled preloading documents (documents were loading on both servers in the cluster instead of just 1

                      If anyone has any other tricks to try let me know. It seems that the 'search' functionality seems a lot slower on large, unique fields in QV9.6. I like the yellow highlight, but it seems to have slowed us down quite a bit. Has anyone else experienced that?