10 Replies Latest reply: May 3, 2016 6:47 AM by Andries Triegaardt RSS

    Can't get the Get Ticket authentication example to work with QlikView 10

      Does anyone have a working get ticket example that works with QlikView 10 or can give me a pointer as to what I'm doing wrong? The example that's included in the Authentication section from the SDK refuses to return a ticket for me. All it did was give me a blank alert box when I clicked on the "Ticket" button after I replaced the server and user placeholders.

      Here is what I'm trying to do:

      The url I'm passing in is http://ServerName/QvAJAXZfc/qvsviewclient.aspx?admin=<Global method="GetTicket"><UserId>AnotherUser</UserId></Global>

      "ServerName" is the name of our server and "AnotherUser" is a valid user.

      I can see the initial xmlhttp.open's POST request in the server log but all it does is return a "Empty Request" in the result message text. The same happens with a GET.

      If I use http://ServerName/QvAJAXZfc/qvsviewclient.aspx?cmd=<Global method="GetTicket"><UserId>AnotherUser</UserId></Global> with the same parameters, I get a "failed to open document, file not found" error in the resulting XML.

      Finally, if I first run http://ServerName/QvAJAXZfc/Authenticate.aspx and then run the second url, I still get the same error in the returned XML but on the server log, it does create a client and issue a ticket. However, the client is using my username and not the one from parameter I passed in, "AnotherUser".

      Thanks for any help on this matter.