7 Replies Latest reply: Jul 6, 2016 2:08 PM by Ian Wilson RSS

    Does QlikView 11.2 SR10 support .Net Framework 4.6?

    Vindhya Giri

      Hi,

       

      Recently when we did a vulnerability scan,  got 'Microsoft .NET Framework Unsupported'. Planning to upgrade to .NET framework 4.6

      Does QlikView 11.2 SR10 support .Net Framework 4.6?

      When I looked into the system requirements of 11.2 SR10  it says 4.0.

      If 4.6 is not supported by QV 11.2 SR10, what would be the best step that can be taken to overcome the vulnerability.

       

      Thanks

       

      Regards

      Vindhya

        • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
          Stefan Wühl

          Not 100% sure, but doesn't say the sys req. document 4.0 or higher?

          (AFAIR, at least more recent system requirements stated that)

           

          Beside this, you may want to have a look into upgrading to a more recent QV server version, too.

          Latest SR for QlikView 11.20 is SR14. There were some security issues resolved between SR10 and SR14, e.g.

          QlikView 11.20 Service Release 12 now available - Security Release

           

          Not to mention that there is QV12 available, too.

            • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
              Vindhya Giri

              Hi swuehl,

               

              The most recent System requirements doc of QV11.2 SR14  states that it supports .NET Framework of 4.0 or higher. But when I saw the sys req doc of QV11.2 SR10, it said .NetFramework 4.0.

              Does, SR make a difference to the .NetFramework support?

               

              Thanks

               

              Regards

              Vindhya

                • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
                  Stefan Wühl

                  Well, it's probably best if maybe bbt or ltu could help us out here, with regard to both the software compatibility and Qlik support contract restrictions.

                    • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
                      Brett Bleess

                      Hey guys, coworker pointed me to your post, key thing to understand here is .Net Framework is a Microsoft component, and they, like us, strive to make things backward compatible, but there can always be issues with things just like when you try to run different client and server versions etc.  The best advice I can provide you on this is to do a thorough regression test on a 4.6 client to ensure everything works as you expect, if so, then you should be fine applying the update. 

                       

                      One other point of note, 11.20 SR14 is the start of official support for Windows 10 OS, although I have been running Windows 10 since last summer with the prior SRs with little to no issues, so everything should be fine, the key thing with the System Requirements is this points out what R&D will entertain looking into in the way of issues, so if something is not listed there, what it means is if we run into any issues with things not listed there, we in support cannot really pursue further review of an issue if a listed component shows no issues.

                       

                      Also keep in mind the statement of .Net Framework 4.0 refers to the overall 4.0 framework, which includes the 4.x releases, Microsoft has a bit of a strange versioning system in that in one place it always shows 4.0.x, but in the Updates area, you see 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 etc.  All of these are still really part of the base 4.0 framework, they are just major point releases, like our 11.00 to 11.20.

                       

                      I hope this helps guys, again, my recommendation would be to update a client and run a set of tests to ensure you see no issues, if things look good, proceed with your updates.  That being said, I always recommend staying current on service release (SR) updates as well, SR's are really the same thing as monthly Windows Updates, we just do not release them as often, but they are bug fixes, so always good to have more fixes than less.  Again, you definitely want to put the SR releases through at least a small test bed of primary apps and functionality to be sure everything is working well though before upgrading, and if you find any issues, please be sure to open a support case with us to have us look into things with you.

                        • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
                          Vindhya Giri

                          Hi Brett,

                           

                          Thanks for the helpful reply. Will keep you and swuehl posted on my trials.

                           

                          As you mentioned, 'it is always good to stay current on service release updates', currently, we are planning to put the SR 14. But at the same time, also taking QV12 into consideration since QV11.2 end of life is Dec 8th 2017 which is not too far. Thus, considering either upgrading to QV12 is a better option or is it better to put SR14.

                           

                          Can you both please share your opinion on this as well? 

                           

                          Thanks

                           

                          Regards

                          Vindhya

                            • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
                              Ian Wilson

                              An update of QlikView 11.2 to the newest Service Release, should be minimal change for change management policies.  We always encourage staying on the latest Service Release.  A decision to move to QlikView 12 should have more consideration.  The differences between 11.2 and 12 in a nutshell: the user experience for both end-users and QlikView admins will be the same.  The changes are "under the hood" so to speak.  With QlikView 12, we have improved how the Qlik Engine performs, and we have done security hardening of the code to meet the US Dept of Defense standards.

                      • Re: Does QlikView 11.2 SR10 support .Net Framework 4.6?
                        Vindhya Giri

                        Hi Swuehl,

                        Can you please provide your inputs on this post as well?  Not sure if this is some how related to the QV version being used.

                        QlikView and  IIS for SSL configuration

                         

                        Thanks

                         

                        Regards

                        Vindhya