4 Replies Latest reply: Sep 30, 2016 7:17 AM by Fabian Santi RSS

    QlikView BEx Extractor Key Figure rounding

    Fabian Santi

      Dear Community,

       

      We have the issue that Key Figures extracted via the QlikView BEx Connector are rounded to the nearest unit. We tried to change the parameters of the BEx queries to by defauld display 3 digits, which show up correctly in BEx Analyzer. However, this had no impact on the extracts made through the QlikView BEx Connector.

      Can you please advise? Did someone else encounter this issue?
      Thanks in advance for your responses,

        • Re: QlikView BEx Extractor Key Figure rounding
          Mats Olin

          Hi, have you checked the display settings in QV to make sure that it is not the settings for the field in QV that removes the decimals?

           

          / Mats

            • Re: QlikView BEx Extractor Key Figure rounding
              Fabian Santi

              Hi Mats,

               

              I am quite certain it is not the display setting in QV. For example, Financial values (in dollars) do not get rounded, but amouts (quantityof materials) do. Both get treated the same way by the extractor, and the QV display is set to show all digits. This makes me believe it is caused by the query configuration, but our configuration asks to show three digits.

               

              My best lead comes from here: Decimal Places Setting in Bex Query Designer | SCN

               

               

              Does anyone know if the QlikView BEx Extractor takes into account the checkbox "Use Default Settings" when making the extract? I'm asking because the digits show up correctly in BEx Analyzer.

               

              Thanks for your help

               

              Fabian

            • Re: QlikView BEx Extractor Key Figure rounding
              Michelle Le

              Hi Fabian, did you manage to resolve the issue?

               

              I am experiencing the same with our "Work Order" key field. The settings in the BEx designer shows that the max length set is "12". However, using the QlikView BexConnector to run the query, it is only ever returning a max of 10 characters on that field only.

               

              Examples:

              • "92006029" - returns correctly
              • "JA1370107" - returns correctly
              • "Z00000201528" - returns incorrectly and truncates the last 2 characters "Z000002015"

               

              I have tested other Key fields in the same query, and we can get up to 20+ characters returned, so it appears that there may be a setting specific to this field?

               

              Also - I tried the same using the OLAP Connector, and the field returns all 12 characters correctly. The BEx Analyzer is also displaying correct results.

               

              Any ideas?

              • Re: QlikView BEx Extractor Key Figure rounding
                Fabian Santi

                Hi all,

                 

                 

                I will put the thread to resolved. The issue for us is in table T006 of the underlying SAP system. The setting without decimals was encoded there, and overriding any other settings when we used the QlikView BEX extractor.

                 

                We were unable to make any changes in the T006 tables, because it would impact too many reports. Instead, we created new Key Figures in the BEX reports which were dimensionless. This way, they were not impacted by the limitations set in T006 which are specific to the UoM. Then we extracted both key figures, one to obtain the unit of measure, and one to obtain the non-rounded data.

                 

                The links below might be of help, they describe our issue:

                - BEx rounding Key Figure | SCN

                - Rounding - for Key figures | SCN

                 

                I hope this will help someone with the same issues. Thanks for the support in the community.

                 

                Best,

                 

                Fabian