1 Reply Latest reply: Feb 16, 2011 8:35 PM by Vlad Gutkovsky RSS

    Unwanted QV Login cookie set

      Hello

      AccessPoint Ajax - QV server 9

      We are experiencing the following problem. All of the QV apps have anonymous access set. We are iFraming our AccessPoint as well to integrate into various websites.

      Problem. At times a user will click on a broken URL link or or just arrive somehow at out AccessPoint with a non-functioning URL request. Even though all the QV apps are set to anonymous access an improperly formatted QV URL request will trigger a LOGIN request. Of course the user cancels that request.

      Here's the problem. The Login request sets the following cookies even if the user cancels the login request.

      cookie_name: Login User value = true

      cokie_name: qlikmachineid

      If the user again attempts to access a proper URL for even an anonymous QV app they are still asked provide login info.

       

      Is there anyway to delay setting the Login cookie and its value till after someone has logged in for real.

       

      TIA & my best

      Stoney

        • Unwanted QV Login cookie set
          Vlad Gutkovsky

          Stoney,

          Great question! I've also experienced the frustration of QV cookies. After much digging, I discovered that the qlikmachineid cookie is created during one of the function calls embedded in AccessPoint.dll. The text in the dll is partially encrypted, so decompiling and recompiling is not an option because the encryption algorithm is not known. So modifying the process of the cookie creation is not an option unfortunately.

          Although you can probably just disable cookies altogether using IE security settings, I suspect that this will cause problems accessing the AccessPoint altogether, although it's certainly worth a shot. By default, there are 2 settings in the Intranet zone for IE that are relevant to you: (1) cookies, and (2) sending user credentials. You can try disabling them both, and if that fixes your problem then push that out to your users via a GPO.

          In any event, you need to make sure you are forcing anonymous authentication in QEMC --> System --> QlikView Servers, as well as in IIS (by enabling Anonymous and disabling Windows) if relevant.

          Good luck!