7 Replies Latest reply: Jun 24, 2016 8:21 PM by Hugo Cordova RSS

    Qlik Sense Desktop OLEDB Dialog does not show providers list

    Hugo Cordova

      Hi,

       

      My SQL OLEDB Connection was working fine. At some point, I tried re-loading the data, and the connection failed. I deleted the connection and tried to create a new one to the same SQL server, but the OLEDB dialog does not pass the second page where you are suppose to select the Provider because the list of Providers is not loaded. I tried to create an ODBC connection, but it does not show any of the data sources.

       

      Since I have QlikView as well, I tried both ODBC and OLEDB, and both work fine.

       

      The error log has the entry:

       

      WARN    20160623T132614.632-0400    11600    8456    Personal\Me    20160623T131940.000-0400    UNSPECIFIED: Filesystem::Find: boost::filesystem::directory_iterator::construct: The system cannot find the path specified: "C:\Users\MyName\AppData\Local\Programs\Qlik\Sense\..\..\prod\client\Client\src\web\extensions"

       

      I would appreciate any help as I am evaluating Qlik Sense for an important customer.

       

      Thanks.

       

      Hugo.

        • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
          Ricardo Gerhard

          Dear Hugo,

           

             I guess this log error isn´t linked with OLEDB situation. The drivers installed or other software can be causing this symptons or a security rule applied.

             Follow a few steps do workaround and analyze it:

          - Restart server and try to create a simple OLEDB conection;

          - Try to create a ODBC connection;

          - Try to create a OLEDB connection to other location;

          - Try to create the connections with other user configured like root admin;

           

          Regards,

          Ricardo Gerhard

            • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
              Hugo Cordova

              Thank you Ricardo,

               

              There must be some type of bug. I tried what you recommended and a bit more.

               

              - I disabled all antivirus, including the Windows Firewall

               

              - I tried to create ODBC connection - sometimes it shows the User DSN data sources, but some other times, it does not show them at all - When they are shown and try to connect to the data source, it fails with:"You do not have Access to the Data Source" - However, it works in Qlikview, not in QlikSense.

               

              -I tried to create and OLEDB Connection - it only takes me to the Select Provider, but it does not show the list of providers. Again, it works in QlikView, not in QlikSense

               

              -All the work is being done as Admin, all along since the time everything worked fine.

               

              -I checked the latest changes to my computer, and I only found that I installed MS Outlook-365 2016 recently - Will that be a source of conflict?

               

              I am kind of disappointed on what it seems to be a very fragile/weak QlikSense solution. I have found other postings with the similar problem "You do not have Access to the Data Source""  and they remain unresolved.

               

              I hope you can shed some light.

               

              Hugo.

                • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
                  Ricardo Gerhard

                  Ok Hugo,

                   

                     I understand and I know that all situations can be and need to be analyzed to Qlik Support in order to solve your problems and realize your sale. Qlik Sense is a good product, with a lot of resources to get a excelent ROI and I never see something like you mentioned. This situation could be lynced with system operational configuration as I mentioned.

                     Open a ticket on Qlik Support to analyse your situation. They going to get a answers.

                   

                  Have a great day,

                  Ricardo Gerhard

              • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
                Michael Tarallo

                Hello Hugo,

                 

                First you may also evaluate Qlik Sense easily without any software to install by using Qlik Sense Cloud - go to qlikcloud.com to register.

                 

                Check out these resource as well: New to Qlik Sense Videos

                 

                Issue like this one are usually environmental so they are difficult to solve remotely and with just Qlik Community support.

                 

                In regards to your issue: Were you logged into the machine with the same id that installed Qlik Sense Desktop?

                 

                Qlik Sense Desktop is a free product licensed for individual business or personal use, so when we install it, you do not have the option to choose the installation path. By default it will get installed in:

                 

                C:\Users\<user>\AppData\Local\Programs\Qlik\Sense\

                 

                I'm wondering if something happened to the user profile,

                 

                If you go here using windows explorer C:\Users\mtarallo\AppData\Local\Programs\Qlik\Sense and search for the path mentioned in the log, does it exist?

                 

                If you can provide some screenshots as well that will be helpful too.

                 

                 

                Please mark the appropriate replies as CORRECT / HELPFUL so our team and other members know that your question(s) has been answered to your satisfaction.

                 

                Regards,

                Mike Tarallo

                Qlik

                  • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
                    Hugo Cordova

                    Thank you Michael. I appreciate it.

                     

                    Yes the path exists exactly as you mention. The product was working fine. However, at some point started to behave abnormally. The only major recent changes to my computer were:

                     

                    I installed MS Outlook 365.

                    Automatic upgrade to Mozilla

                    Automatic update to Skype

                    Automatic update to Adobe

                     

                    Nothing else. I am running Windows 7.

                     

                    Below you will find the screen shots showing that when I try to connect via ODBC, it does not load any of the data sources. Yesterday, it showed the data sources, and when clicked on one of them, it gave the error" You do not have authority to the data source"

                     

                    The other screen shot shows that when creating an OLEDB connection, it does not load the Providers List.

                     

                    I want to highlight that the same ODBC data sources and the OLDDB connections to SQL Server work perfectly using QlikView. So it must be something unique on how QlikSense attempts to create data connections.

                     

                    As additional information. Yesterday, I uninstalled QlikSense -  and re-installed it with a new admin user, but the issue was not resolved.

                     

                    I truly appreciate your interest.

                     

                    Hugo.

                     

                     

                    1. When creating and ODBC Connection – it takes at least 2 minutes to show the screen:

                     

                    P1.png

                     

                         It does not show any of the data sources(user/system 32/64) - yesterday it showed them, but there was an authority issue:

                    P2.png

                     

                     

                    When trying to create an OLD DB connection, it does not load the providers list

                     

                    P4.jpg

                      • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
                        Harvey Johal

                        Just a thought to look into:

                         

                        From the thread, issue appeared after installing Office 365.  Software doesn't essentially stop working unless something changes and it sounds like in this case, a potential upgrade to the MDAC layer/OLEDB may be the culprit (Microsoft Data Access Components - Wikipedia, the free encyclopedia).  I think Microsoft may have a utility to check the underlying layer - I've performed a quick Google search on utilities and it's come back with an MDAC Checker for old operating systems (ie. Win 2000, XP, etc..) and there some mention of System File Checker built into Windows 10 to scan and resolve system file corruption.

                         

                        You may want to look here first as I'm leaning more towards it a system issue with your OS/MDAC layer and you're seeing the symptoms of the issue in Qlik.  

                          • Re: Qlik Sense Desktop OLEDB Dialog does not show providers list
                            Hugo Cordova

                            Thank you for all your feedback.

                             

                            Finally, I figure out the problem. The culprit was Microsoft Security Essentials. It seems than when installing Outlook, MSE was updated as well, and it started to distrust the QlikSense sub-processes such as QlikSenseBrowser and QVConnect64. QlikSense.exe was still trusted, but it was the other sub-processed, and that is why it made more difficult to figure it out.

                             

                            I have shut off MSE, and everything works fine.

                             

                            Hugo.