0 Replies Latest reply: Jun 23, 2016 10:58 PM by Syed Ismael Hamid RSS

    Upgrade 2.0.1 to 2.2.4 failed.

    Syed Ismael Hamid

      Hi all.

      I am upgrading my testing server from 2.0.1 to 2.2.4 but it is not successful.

      here was the situation/scenario that happened:

      - backup my server

      - stop all services excent repository database

      - while running SenseCleanupScript.cmd as administrator, it gave this error:

       

      psql:C:/Users/visorservice/Desktop/SenseCleanupScript_v1.2/SenseCleanupScript/CleanupSenseDb_2.0.sql:127: ERROR:  update or delete on table "CompositeEvents" violates foreign key constraint "FK_CompositeEventTimeConstraints_CompositeEvents_ID" on table "CompositeEventTimeConstraints"

      DETAIL:  Key (ID)=(b63b0d62-705c-4dec-9e90-c04fc399d7db) is still referenced from table "CompositeEventTimeConstraints".

       

      - i had ignored this error and carry on with running the qlik_sense_setup for version 2.2.4

      - after "successfully" installed, i had went to QMC but it did not load.

      - checked the services and realise all but the repository database is running. the database had stopped by itself.

      - right click and start services but it will force it self to stop.

      - the local system was logged on.

       

      any input on this?

      Thanks in advance