5 Replies Latest reply: Jun 29, 2016 6:50 AM by Eamonn O'Brien RSS

    QlikView Desktop Client - ActiveX prompt

    Eamonn O'Brien

      Hi Guys

                   

      We are currently having an issue at the moment  with regards to packaging a version of the QlikView desktop client where we have the QlikView access point appear when the application starts up for end users.

      We had an issue that when a user first open up the new QlikView Desktop Client application a Windows Security Warning ActiveX prompt appears.  The user has to click the Yes button on the warning prompt before the access point is loaded.

       

      p2.jpg

       

      We found out that doing the following resolves this issue.

      • Go to Settings -> Internet Options -> Security -> Trusted Sites -> Custom level, the ActiveX Warning is not prompted anymore.
      • Find ‘Initialize and script ActiveX controls not marked as safe for Scripting’ setting
      • Set it to Enable.

      p1.jpg

      As this will be rolled out to all business end user users, the above cannot be done due to our company IT security policy so to overcome this, we have looked into creating a registry entry that will do the above to listed sites when the application is installed. (Qlik Access Point). Unfortunately, we cannot seem to get this working. I know that we may need the CLSID for ActiveX component of the QlikView desktop client.

      [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{5AE58FCF-6F6A-49B2-B064-02492C66E3F4}\iexplore\AllowedDomains\http://qlik.inhouse.paddypower.com/home/index.htm]


      Link to description of the above solution:

      https://ardamis.com/2015/04/20/practical-administration-of-internet-explorer-activex-controls-using-group-policy/

       

      Any help on this would greatly appreciated.

       

      Cheers

      Eamonn