5 Replies Latest reply: Aug 11, 2016 7:43 AM by Peter Turner RSS

    Losing all CALs after Qlikview Services Restart

    Av mES

      Hi Community,

       

      We have a problem where after a Restart of the Qlikview Services or a Server Reboot, all Named CALs and Document CALs are wiped out.

       

      The Licenses tab in QMC shows:

       

      - Named User CALs: '0' assigned ('X' in license)

       

      - Document CALs: '0' assigned ('Y' in license)

       

       

      This issue has started occurring since only 2 days, and we had to assign CALs all over again to the users of each document whenever we had to restart the services.

       

      A few details of our system:

       

      QMS@qlikviewserver
      Product Information
      Product nameQMS Backend Core x64
      Client Build Number11.20.12664.0
      Target Platformx64
      Publisher License KeyNo License
      Service authenticationAD groups
      Machine Information
      Computer NameQLIKVIEWSERVER
      Operating System VersionWin32_OperatingSystem=@ X64 (Microsoft Windows NT 6.1.7600.0)
      .NET Version4.0.30319.17929
      Physical Memory196562Mb
      Available Memory111031Mb

       

       

      QVS@qlikviewserver at qvp://172.16.0.12/
      Server System Info
      Operating SystemWindows Server 2008 R2 Enterprise (64 bit edition)
      Operating System Version6.1.7600
      Wow64 modeNot using Wow64
      QlikTech ProductQlikViewServer 64-bit Edition (x64)
      Product Version11.20.12664.0
      Server License KeyXXXX XXXX XXXX XXXX
      CPU Targetx64
      Country1 United States United States
      Language0409 English (United States) English
      Server CollaborationDisabled
      Number of CPUs24
      CPU 0Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 1Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 2Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 3Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 4Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 5Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 6Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 7Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 8Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 9Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 10Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 11Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 12Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 13Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 14Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 15Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 16Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 17Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 18Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 19Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 20Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 21Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 22Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      CPU 23Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz 2000MHz
      Physical RAM(MB)196562
      VMCommitted(MB)80169
      VMAllocated(MB)94108
      VMFree(MB)111031
      VMLargestFreeBlock(MB)111031
      Local Time2016-06-30 20:37
      GMT Time2016-06-30 15:07

       

       

       

      Any help on this issue is appreciated or point us to a direction where we may get a solution to this problem.

      Thanks in advance.


      Regards,

      Avishkar

        • Re: Losing all CALs after Qlikview Services Restart
          Peter Cammaert

          A number of bug fixes applied to later SRs are related to disappearing CALs, even one that drops CALs after a server reboot by corrupting the .pgo file and was fixed in SR13. Time for an upgrade from SR9 to SR14?

           

          Peter

          • Re: Losing all CALs after Qlikview Services Restart
            Celso Bejec

            Hi avishkarm,

             

            We also got similar issue before. In our case the .pgo files (BorrowedCalData.pgo, CalData.pgo, etc.pgo) were out of sync. Check if these files have similar timestamp in you server. They are located at the root and qlikview server folder.

             

            I did the followings steps.

            1. Stop qlikview services.

            2. Back up all pgo files from both locations (root and qlikview server)

            3. Delete pgo files then restart services.

             

            Once services are restarted new .pgo files were generated. You have to assigned doc cal and name cals to your users again.

             

            A good discussion about this can be read here Assigned Cals are getting deleted on the qlikview server

             

            Hope this help.

            • Re: Losing all CALs after Qlikview Services Restart
              Joseph Morales

              Hi avishkam

               

              Do you have an antivirus on the server? if you so exclude the antivirus scanning from ProgramData\Qlikview, because other than deleting them also it locks the file from writing and reading, specially the BorrowCalData.pgo gets out of sync from either root folder copy and Qlikview\QlikviewServer folder. So when one of the PGOs are out of sync, the assignment CALs that you see on the QMC reminds in memory; however, when you reboot the machine, that memory gets cleared and CALs assignments are gone, because the QMC cannot read those PGOs anymore.

               

              The default folders to store the pgo files are the followings:

               

              o C:\ProgramData\QlikTech\QlikViewServer (Backup files of pgo files. Is a copy of Documents)

              o C:\ProgramData\QlikTech\Documents (Files that are using by the console in real time)

               

              After exclude the antivirus scanning follow this steps:

              1.- Stop QlikView Server Services.

              2.- Delete pgo files from these folders.

              3.- Start QlikView Server Services.

              4.- Assign CALs all over again to the users

               

              Regards

               

              Joseph

              • Re: Losing all CALs after Qlikview Services Restart
                Ronnie Taborn

                I recommend that you upgrade. Do your PGO files have the same time stamp?  Do you have any Chinese characters on the PGO files?