2 Replies Latest reply: Apr 6, 2011 2:34 AM by josefkriebel RSS

    Scheduled job runs forever in QV Server

      Hi Guys,

      My scheduled job's in server (all) start and then stay in status "running" until I manualy cancel them.

      When canceled, the error desc is:

      Document open threw an exception. Exception=The currently executing operation was aborted.
      The sourcedocument failed to open.. Exception=System.NullReferenceException: Object reference not set to an instance of an object.
      at QVBWrapper.Document.Load(ILogBucket i_LogBucket)
      The document failed to open.
      Task aborted.
      The task "QV Projects/System/eService Data Sync/sync.qvw" failed. ErrorCount=4

       

      Anybody have an Idea on what I can do to fix it?

      Thanks

      Michiel

        • Scheduled job runs forever in QV Server

          I'm getting this same error since 31st March myself and don't understand it as we've made no changes to our configuration whatsoever. It's very strange.

          Sorry I can't give an answer now but if I find the solution I'll be sure to post.

          Graeme

            • Scheduled job runs forever in QV Server

              Hi Graeme,

              Make sure to backup your data before trying below steps and note that I got these problems after I upgraded from V9 SR6 to V10 SR2 beta.

              I managed to solve this problem, what worked for me is:

              1. Completely uninstall existing Server from control panel.

              2. Remove the folders under C:\ProgramData\QlikTech

              3. Remove the registry settings under HKEY_LOCAL_MACHINE\SOFTWARE\QlikTech.

              If this does not fix it you probably have security build in to QVW's that you are trying to schedule in server.

              1. Remove Document security.

              • Document Properties, opening tab
              - Initial Data Reduction Based on Section Access
              - Prohibit Binary load

              2. Remove Hidden script

              • In script, menu => file => hidden script (for access restriction)

              3. Reload project manualy.

              Please let me know if this helped~

              Thanks,

              Michiel