5 Replies Latest reply: Jun 27, 2011 7:31 AM by Alecsandru Bucur RSS

    Services are not running in Qlikview Server 10

      Hi everyone,

      I am having a problem with the services of QlikView Server 10. I am trying to look for a solution in the community but could not find one. I hope someone here had the same issue before and give me some hints.

      I've successful installed QlikView Server 10 and apply the license. However, 3 services are not running DSC, QVWS, ReloadEngine. Someone had suggested to update the .NET framework 3.5 sp1. However, I've installed it in Windows Server 2008 R2 which .NET 3.5.1 is already installed (enabled). Any hints?

       

      Thanks,

       

        • Services are not running in Qlikview Server 10
          Peter Turner

          Hi Chris,

          The only thing i've try is to check the log files.
          The windows event log should say why the service could'nt start, or the QV logs located at C:\ProgramData\QlikTech\Qvs\LOGS.

          Happy debuging!

          • Services are not running in Qlikview Server 10
            Erich Shiino

            It's good to check the logs, I agree.

            In the mean time, you can check if the users running the services are correct (user an password).

            I had a problem last week (more or less like this). I solved it when I included the user running the services in the QlikView Administrators group

              • Services are not running in Qlikview Server 10

                Hi all,

                All services are running under Administrator account. I have looked into the Event log and found some of the errors below.

                Source: DirectoryServiceConnector

                Parse error setting up resource C:\ProgramData\QlikTech\DirectoryServiceConnector\Resources\acc004d6-cf2d-4fd2-80d9-4ee024d2170e: The given key was not present in the dictionary.

                 

                 

              • Services are not running in Qlikview Server 10

                I'm having the same problem.

                Anyone found a solution ?

                 

                I have installed Qlikview Server 10 SR1. Could it be related to this SR? Do you think i should try installing SR2?

                 

                10x in advance

                 

                Alecs

                • Services are not running in Qlikview Server 10

                  I solved the problem.

                  i noticed that in the C:\ProgramData\QlikTech\DistributionService folder there were only 3 files:

                   

                  LoadBalancer.xml

                  Notification.xml

                  NotificationDetalis.xml

                   

                  So there had to be something wrong with the Distribution Service.

                  I searched other xml file in the C:\ProgramData\QlikTech\ManagementService\QVPR and found this refernece to the Distribution Sevice: DistributionService XSWebAdress="http://qliktest:4720/qtxs.asmx"

                   

                  I tried to open it in IE, but it didn't work. So i replaced qliktest (the name of the computer where the server is installed) with localhost and the page showed this:

                   

                  <Root>QlikView Distribution Service v10.0.8935 (10.0.8935.7, ID=06c38421-9735-008b-cd65-3c83b168f58f) says, "Hello world. The time is: 6/27/2011 13:46:09.2638247".</Root>

                   

                  Aferwards, the service started and it has been runnig without problem for 2 hours.

                   

                  I can't explin why this solution worked , maybe it has something to do with a DNS problem (the service didn't know who qliktest was, but it recognized localhost).

                   

                  Hope it helps, it solved my problem.