1 Reply Latest reply: Aug 23, 2016 8:58 AM by Alex Walker RSS

    Qlik Sense Server Error 400 with WSO2 SAML SSO

    Henry Hu

      Hi,

       

      has anyone tried to integrate Qlik Sense Server with WSO2 Identity server?  We tried to configure it and till now we can't get the two to work together.  It is kind of frustrating that we keep on getting Error 400. One thing that we did observer that is we dont have any Attribute Statement in our SAML Response.  However, when we use the default WSO2 web application, it did return the Attribute Statement in the SAML Response message.  Now either there is something we did not do in WSO2 or do we need to have another application sitting in the middle to generate the Attribute Statement??  Hope someone can help us out.  Thanks.

        • Re: Qlik Sense Server Error 400 with WSO2 SAML SSO
          Alex Walker

          I've not done it with WSO2 but I have with Google Apps and Wordpress. Google works, but I currently get a 400 error with Wordpress - I believe this is down to Wordpress not signing the response. Not sure if you have the same issue or not.

           

          As far as I know there shouldn't need to be anything in the middle other than your browser... but I'm not familiar with WSO2. In Google I had to set up attribute mapping, perhaps that needs configuring?

           

          Either way, it might be worth posting some more information - e.g. the metadata XML that you've put into Qlik Sense (with anything private removed of course), sample requests / responses so people can see more detail.