3 Replies Latest reply: Jul 9, 2010 1:03 PM by s j RSS

    SAP Connector fails after QV 9 upgrade

    Trevor Roth

      I am testing an upgrade from 8.5 to 9. I have noticed that my SAP Connector seems to have broken as a result of the upgrade.

       

      I have two test environments:

       

      Developer Workstation

      OS: WinXP SP3 (32-bit)

      QlikView Desktop: 8.50.6326.5

      QlikView SAP Connector: 5.1.6680.0

       

      Server

      OS: Winows Server 2003 R2 SP2 (64-bit)

      QVS: 8.50.6231.5

      QVP: 8.50.6232.5 (Enterprise Edition)

      QlikView SAP Connector: 5.1.6680.0

      Running IIS

       

      In this configuration my apps run fine.

       

      I then upgrade the above environment to QV 9 SR3.

       

      Developer Workstation

      OS: WinXP SP3 (32-bit)

      QlikView Desktop 9.00.7436.8 SR3

      QlikView SAP Connector 5.1.6680.0

       

      Server

      OS: Winows Server 2003 R2 SP2 (64-bit)

      QMS: 9.0.7436.8

      QlikView SAP Connector 5.1.6680.0

      Running IIS

       

      My applications that load from SAP fail in both environments, while all other applications run fine in both environments. I create a new application, open the load script, click on custom data tab, then look at custom data sources I see the SAP Connector as an option. When I select it and click the connect button I get a few different types of erratic behavior (either one or the other, not both at the same time).

       

      1) QlikView will seem to freeze up for a while and eventually return with a error dialog box titled QvSAPConnector. The message states: 'The connection with the server was reset'.

      2) A 'Registration' dialog box. Message: 'Could not connect to the LEF Server. For offline licensing, please paste your LEF text in the field below'. I do not have the LEF Information for the SAP Connector (not sure how to get that), but if I attempt to put in the LEF information I do have (for the server or desktop) it does not take.

       

      I have checked the obvious - like mixing 32-bit software on a 64-bit OS, etc. I am confused as in 8.5 I've not needed to enter LEF information for the SAP Connector. Also, all the other Qlikview products can contact the LEF Server fine. I have successfully reentered my license and control number for QV Server and desktop without error.

       

      Any ideas?

       

       

       

       

       

        • SAP Connector fails after QV 9 upgrade
          Rakesh Mehta

          Hi Trever,

          It seems your installation (dll, etc.) are corrupted. I would recommend that you uninstall the connector and re-install it.
          Regarding LEF, you must contact your QlikTech counterpart or Partner to get the manual LEF for SAP Connector. The Server or Desktop LEF will not work. SAP Connecter get's it's own license, thus a separate manual LEF file. You would need to enter this LEF only once and then it will never ask again.

          While re-installing the connector, you may want to install 5.3 version out there. Comes with new SAP transports and many additional connection options. I know it's not easy to "just" upgrade it, but as far as I know, there are no major changes in the basic SQL connector portion.

          Hope this helps you.

            • SAP Connector fails after QV 9 upgrade
              Trevor Roth

              Rakesh - you were exactly right.

               

              Uninstalling / reinstalling the SAP Connector did nothing. I emailed QlikTech and got a LEF file within two hours. My applications are now refreshing normally.

               

              I know the newer connectors have some great features. As you know, SAP Connector upgrades are not "simple" tasks. J One thing at a time…

               

              Thanks!

            • SAP Connector fails after QV 9 upgrade
              s j

              You have to rplace previously paste file in SAP Environment with New version's file . then only it work fine.

              In this case you have to paste new version's file in SAP environment with the help of SAP Basis Expert.