12 Replies Latest reply: Oct 23, 2012 4:27 PM by Fernando Augusto Schmitz RSS

    ODBC read fails

    MANOJ_AGRAWAL

      Hello,

      I am facing a strange problem. I am connecting to my microsoft sql server using ODBC and the connection is successful. I am able to select tables and am able to see the data in the table rows and columns. But when I save and load, the read fails giving me an error

      ODBC read failed
      SQL SELECT *
      FROM "TMS_Data".dbo.billingterms

      Can someone help on what's going on?

      regards,

      Manoj Agrawal

        • ODBC read fails
          Rakesh Mehta

          I have seen this sometimes. You may need to close the QV completely, exit out and restart app and it should be fine.

          • ODBC read fails

            Hi Manoj,

            I'm not sure if this has been resolved for you, and I don't have an answer. I have a similar problem. I think mine stems from using an ODBC driver on my 32-bit development environment calling a stored procedure on SQL Server 2008 64-bit. We just went through a migration from SQL Server 2000 32 bit to SQL Server 2008 64-bit. All of my stored procedures that were written prior to the migration work fine, but a new one is not. I can run it in the Management Studio just fine, but I get a ODBC Read Error in QlikView. I think it has something to do with when the stored procedures were compiled. Our technicians restored a backup from the SQL Server 2000 to the SQL Server 2008. I think in doing it that way the old stored procedures weren't recompiled. I did some digging and found SQL error codes, but they don't have a Read Error. So is this issue an ODBC issue or a QlikView issue?

            Here's the link to SQL error Codes.

            Allen

              • ODBC read fails
                MANOJ_AGRAWAL

                Allen,

                As mentioned in my previous post, yes I got it working. Deleted the work 'ODBC' from the connection string so that it uses OLE DB connect by default.

                So now my connection string reads

                CONNECT TO WEBTMS etc. etc etc.

                instead of

                ODBC CONNECT to WEBTMS etc etc etc

                regards,

                  • ODBC read fails

                    Hi,

                    I also have the same problem and have tried removing the 'ODBC' but still get the same issue, well 'OLEDB Read Failed'

                    I'm trying to connect to a MS Access db that I suspect is corrupt?

                    Any ideas?

                • ODBC read fails
                  s j

                  Can give me script which you write for save and load.

                   

                    • ODBC read fails

                      Thanks but I have solved it. The access database I was connecting to seemed to have got corrupted. I went back to the previous backup and now everything works ok. The funny thing was I could open the queries in Access but I guess it must've had something to do with the way Access provides data to other programs

                        • ODBC read fails
                          Miguel �ngel Garc�a

                          The exact same behavior is seen when the user and password are not embedded in the connection string. When you connect to the ODBC/OLEDB and dont type the password in the first window (Called Connect To DataSource) but rather in a subsequent window asking specifically for the user and password, it will not be embedded and you WILL be able to select the tables and all (because you just typed the credentials), but when trying to reload, since it has no password to communicate with the source, it will fail.

                          Mike.

                      • ODBC read fails
                        s j

                        Dear Manoj ,

                        pls Try with OLEDB , it will work fine in my case.

                        Regards,

                        Sunil Jain.

                         

                         

                        • Re: ODBC read fails

                          I took this error ,

                          if you take scritp in db ,  your colomn name musn't similar , you have to give alias this column.

                           

                          select

                             a.name,

                             b.name ,

                             a.aaa,

                             b.dfdfd,

                             b.aaa

                           

                          from a ,b;

                          • Re: ODBC read fails

                            In my case, the problem was the column name length.