5 Replies Latest reply: Aug 18, 2016 7:13 PM by Alex Watts RSS

    QMC Greyed out when using virtual proxy

    Alex Watts

      Hi All,

       

      I have a user which I have granted RootAdmin privileges. When I log into qmc normally without the virtual proxy https:///{servername}/qmc, the user is able to access all the qmc features. However, when I login via the virtual proxy url https:///{servername}/{virtualproxy}/qmc, I am able to login and see the qmc but I cannot access any of the features.


      Any ideas?

       

      Regards,

       

       

      Alex Watts

        • Re: QMC Greyed out when using virtual proxy
          Rohit Kumar

          Hi Alex,

           

          Can you please explain what do you mean by you cannot see any of the feature , Is it appearing like you have no access to QMC.

          See when you are saying User is  Root Admin , So it mean , your user will see all the features enable, but here by your words , you are saying you can login in , It means your DNS is configured fine ,

           

          Did you done that part where , you need to add your soft domain address to virtual proxies=> central proxy =>advanced => Host white list and enable the http  option. please do it if you didn't.

           

          Please let me know if you are still facing any issue

            • Re: QMC Greyed out when using virtual proxy
              Alex Watts

              Hi,

               

              Thanks for the reply. When I say I can't access the features I mean, I can see the QMC screen but cannot access any of the features, see below. The user in question does have the RootAdmin role assigned

              2016-08-18 09_39_20-Qlik Management Console.png

              Without the virtual proxy prefix, I can access the qmc with the same user, see below

              2016-08-18 09_45_18-Qlik Management Console.png

              I have also added the qlik host to the white list. Which is why I'm not sure what is going on.


              FYI I modified my C:\Windows\System32\drivers\etc\host file to manually add qlikproduction based on AWS EC2 public IP address