6 Replies Latest reply: Sep 6, 2016 5:40 PM by Daniel Jenkins RSS

    Nprinting XML task does not run

    Alwyn Louw

      Capture.PNG

      Hi All.

       

      Need assistance.

       

      I am trying to execute an Nprinting task via XML to allow external users to kick off the task by them selves.

       

      I followed the correct process to add as an external request ect.

       

      When I run the task I receive the above screen.

       

      What am I doing wrong?

       

      thanks in advance

      Alwyn

        • Re: Nprinting XML task does not run
          André Gomes

          Hi,

           

          have you read this

           

          How to Execute NPrinting Reports by External XML Request

           

          HTH

           

          André Gomes

            • Re: Nprinting XML task does not run
              Alwyn Louw

              Thanks Andre.

               

              However I have used this process to start with.

               

              The XML does not seem to do any action and it just stays open.

               

              thanks

              Alwyn

                • Re: Nprinting XML task does not run
                  Daniel Jenkins

                  Hi Alwyn,

                   

                  Firstly, your file format is wrong. Assuming that your task is named WDR and the path to your NPrinting project file (.nsq) is correct, it should be:

                   

                  <?xml version="1.0"?>

                  <schedules>

                  <schedule file="C:\QlikView\QVReporting\NPrinting\Applications\Wealth\Wealth Daily Report.nsq" type="task" entityName="WDR" />

                  </schedules>

                   

                  The XML file itself does not do anything. The QlikView NPrinting server service looks in the Source Folder for XML files with the .request file extension. If it finds one, it executes the task or report specified in the request XML file and then renames it to have a .processed file extension. It also creates a file with the same name but with a .result file extension which contains details on the success or failure of the report or task. So:

                   

                  1. Check that your NPrinting Server Service is running

                  2. Make sure you have the Enable external requests check-box checked

                  3. Copy your XML file with the .request file extension to the folder specified in Source Folder

                   

                  Assuming of course that your NPrinting server service is set up and running smoothly. Configuring and Troubleshooting NPrinting Server Service and Schedules

                   

                  HTH - Daniel.

                    • Re: Nprinting XML task does not run
                      Alwyn Louw

                      Hi Daniel

                       

                      Thanks for the extensive response. Really appreciated

                       

                      My format is right. It is only the XML view that displays it incorrectly.

                       

                      <?xml version="1.0"?>

                      <schedules>

                      <schedule file="\PSGMISNPRINT\QlikView\QVReporting\NPrinting\Applications\Wealth\\Solution\Wealth Daily Report.nsq" type="Task" entityName="WDR" />

                      </schedules>

                       

                      I have also made sure that all the necessarily checks was done as per your message

                       

                      1. Check that your NPrinting Server Service is running It does

                      2. Make sure you have the Enable external requests check-box checked It is checked

                      3. Copy your XML file with the .request file extension to the folder specified in Source Folder Also did this


                      Also restarted the services. Still not working. Almost like Nprinting does not even search for the file.



                      Is there anything else that I am missing?

                       

                      Thanks

                      Alwyn