32 Replies Latest reply: Oct 5, 2016 4:29 AM by shay raber RSS

    RAM usage by users won't release

    shay raber

      Hi all,

       

      I'm facing an issue lately with my QV server deployment.

      recently, users tend to get very often an error message saying the server is unreachable (and they can't open documents via access point).

      exploring that issue led me to the conclusion is high RAM usage which is solved only by restarting the Qlikview server service.

      what I've noticed is that users which opens documents increase (as expected) the RAM usage, BUT when they close the documents the RAM they used is NOT releasing... the RAM usage only keeps increasing and increasing until users can no longer open documents until a restart is being made.

      I've read this thread:

      RAM usage high

      which explains that this is how QV originally designed to work (use every available RAM for better end-user experience) but what if that RAM usage effects badly on other users?

      it doesn't seem right to schedule a service restart few times a day...

      any other idea? suggestion?

      please assist

        • Re: RAM usage by users won't release
          Gysbert Wassenaar

          Try lowering the document timeout setting.

           

          From the help file:

          Documents

          On the Documents tab, the settings for document control can be managed.

          Server

          Document Timeout

          Open documents take up valuable system resources (that is, memory space, RAM, is allocated) and should not be allowed to remain open when not in use. However, if a document is closed too quickly, the users may get longer delay times when accessing the document, because the server has to reopen it. This value controls for how long a document will be allowed to be unused before the QlikView Server (QVS) closes the document and reclaims the resources.

          Default value: 480 minutes.

          • Re: RAM usage by users won't release
            Berk Armagan

            Just try to change your document timeout settings which located on QMC->Documents->Your QVD->Server->Performance. Hope it helps you.

            • Re: RAM usage by users won't release
              André Gomes

              Hi,

               

              the RAM is not managed by the QV Server is managed by OS.

               

              My advice is to do a restart at least once a week.

               

              Regards

               

              André Gomes

              • Re: RAM usage by users won't release
                Toni Kautto

                Your question does not clearly describe an actual problem. High memory utilization is not per definition a problem, it would rather indicate a high utilization in terms of allow large cache to enable quick calculation times.

                 

                The server is expected to stay within the working set limits. What is your working set limit? What amount of physical memory do you have? Is the allocation higher than working set limit(s)?

                 

                For best performance and stability, it is recommended to update to the latest Service Release. Which major version and Sr are you currently running?

                 

                In a healthy environment there should be no need for daily restarts.

                  • Re: RAM usage by users won't release
                    shay raber

                    hi Toni,

                     

                    thank you for the detailed reply.

                    as for your comments,

                    Toni Kautto wrote:

                     

                    The server is expected to stay within the working set limits. What is your working set limit? What amount of physical memory do you have? Is the allocation higher than working set limit(s)?

                    besides upgrading to SR15 (I'm NOT upgrading to QV12 now as it less stable, as far as i know) here is the current status of my physical memory:

                     

                    where can I check the working set limit? and how much allocated (if it's higher then the limit or not)?

                      • Re: RAM usage by users won't release
                        Toni Kautto

                        The working set limit is a setting in QlikView Management Console. Look in Performance under the QlikView Server setting. The below link is for QlikView 12 help, but the settings in this area are the same in 11.20.

                         

                        Performance ‒ QlikView

                         

                        I think you mentioned somewhere in this thread that the memory allocation gets close to 50GB. Your server appears to have 82GB, so that means you are no where near to use all your resources. There is generally no reason to worry about memory consumption that stays within your working set limit.

                         

                        The memory is used for the document, ongoing user session and calculation cache. For more detailed studies I would suggest that you read QlikView Server Memory Management and CPU Utilization which describes how memory is allocated, and also explains the memory allocation patterns that you see in Windows Task Manager.

                          • Re: RAM usage by users won't release
                            shay raber

                            hi Toni,

                             

                            the working set limit are 50%-65%

                            you can see also from my reply above that the total memory is 80GB, available 55GB, Cached 30GB and free 25 GB (at that point)

                            the users, at other time then the time the screenshot was taken suffer from system unavailability.they get the following message:

                            restarting the service dropped the RAM usage and issue solved, but that's not the way it should be and i wonder why it happens

                              • Re: RAM usage by users won't release
                                Marcus Sommer

                                Your working set settings are not appropriate. 65% max. from 80 GB = 52 GB which meant that your server runs really out of memory. If there are no further processess on the machine which are needed to be (RAM) protected you should increase these setting to 90-95% or instead of this increase the amount of physically RAM.

                                 

                                - Marcus

                                  • Re: RAM usage by users won't release
                                    Toni Kautto

                                    In addition to Marcus recommendation. It is highly recommended to have a dedicated machine for QlikView, so the it can utilize maximum memory and provide your users with best possible experience.

                                    • Re: RAM usage by users won't release
                                      shay raber

                                      hi Marcus

                                      what do you suggest?

                                      how much to increase the low limit to? and how much the high limit to?

                                       

                                      p.s.

                                      Toni,

                                      the QVS is installed on VM dedicated only for the QV

                                        • Re: RAM usage by users won't release
                                          Toni Kautto

                                          I think Marcus already recommended you to use 90% as lower limit and 95% as upper limit.

                                           

                                          A 95% upper limit will represent 76GB, which leaves 4GB for Windows and other processes that your require to run. Will this be enough for your OS and supporting processes?

                                          - If yes, then set the upper limit to 95%, and the lower to 90%.

                                          - If no, then lower the limits from 90-95% accordingly.

                                          • Re: RAM usage by users won't release
                                            Marcus Sommer

                                            If there is only the qvs running I would increse the lower limit to 70% and the upper limit to 95% which meant that there are 5% from 80 GB = 4 GB for the OS. If also the qvb is running on the machine it would be depend how much both services could to overlap - Are there only some small update-tasks during the usual business-time and most of the work is done during a nightly time-frame you could set it maybe to 90%. If there is more overlapping you would need to look on them more closely.

                                             

                                            - Marcus

                                              • Re: RAM usage by users won't release
                                                shay raber

                                                B.T.W

                                                does it also in addition to limit the Document timeout? as was suggested earlier?

                                                or instead?

                                                there are nightly process mainly, but users are from different zones (China, US, etc.)

                                                and also there is a process that occurs every 4 hours... (1am, 5am, 9am, ...)

                                                  • Re: RAM usage by users won't release
                                                    Marcus Sommer

                                                    To decrease the timeout-settings will help to minimize the risks of running out of memory but then it could happens that the user-experience isn't like before if documents must be loaded into the RAM instead of using the cached document.

                                                     

                                                    I think you should take a look on the QlikView Governance Dashboard to evaluate the min/avg/max RAM consumption over the last month to get a real foundation to decide how much should be the working set settings be and/or to increase the RAM and/or to optimize the tasks and applications.

                                                     

                                                    - Marcus

                                    • Re: RAM usage by users won't release
                                      shay raber

                                      just to update-

                                       

                                      Infra team added more RAM to the machine (144GB instead of 80GB) as a temporary solution (the current resource was NOT enough obviously).

                                      so far so good, but we need to figure out the proper solution which will be either improving documents, splitting documents, adding a new Server just for users and the current will remain for QVS tasks or upgrading to Sense.

                                      timeout of document doesn't help. i've tried to play and adjust the Min/Max working set which helped also (changed from 50/65 to 70/80-85).

                                       

                                      i'll keep updating