1 Reply Latest reply: Sep 26, 2016 5:24 PM by Alex Mumme RSS

    Can't install Qlik Sense 3.1, and can't remove Qlik.Next due to attempting

    Alex Mumme

      So I've ended up in a less-than-fun catch 22. I attempted to install Qlik Sense 3.1 to evaluate what's changed since I last had the opportunity to evaluate Qlik Sense. Unfortunately I hadn't yet removed Qlik Sense 0.90 (aka Qlik.Next) and it gave me the "Qlik Sense Desktop setup - Environment error" message saying that 0.90.0.0 needs to be uninstalled. Now the real fun begins.

      I go to uninstall 0.90.0.0 and get the following error message:

      "QlikView setup 0.90.0.0 - Environment error Unknown upgrade scenario."

       

      If I look at the Setup log I can see that the offending aspect of the environment is expressed by this line:

      "Major upgrade detected. BundleTag:  Operation: None PerMachine: False ProductCode: {d1169b26-f566-472a-a451-ee1417f68cc7} Version: 10.3.5.0"

       

      A quick search of the registry tells me that d1169b26-f566-472a-a451-ee1417f68cc7 refers to Qlik Sense Desktop 3.1

      I look in Programs and Features to discover that Qlik Sense Desktop 3.1 claims to be installed (although it is, in fact, not).

      If I attempt to uninstall Qlik Sense Desktop 3.1 in Programs and Features I again get the Environment error message saying that 0.90.0.0 needs to be uninstalled... which I can't do because 3.1 is installed.

       

      Help?