20 Replies Latest reply: Apr 25, 2011 10:06 AM by rodrigo_acosta RSS

    Display .QVW document on web

      Hi,

      I am newbie to QlikView and have recently installed Qlik View 9 personal edition. I have developed few reports in a .qvw document which i now want to view on web via browser, in other words, i understand that it need to be published to a web server.

      I understand little bit from the documentation that in this process Qlik View server and/or Qlik View publisher might be involved, please correct me if i am wrong. But sadly, i have not been able to find any reference material which lists down the complete basic steps how to achieve this.

      I have Qlik View 9 Personal Edition installed along with Qlik View server, Qlik View Management Console and Qlik View Enterprise Management console. Please let me know if any additional software components need to be installed and what are the basic steps to achieve this using all the components.

      Thanks in advance

        • Display .QVW document on web
          Johannes Sunden

          Hi,

          If you've done a default installation of QlikView Server then it should be up and running already with it's own web server, QlikView Web Server. Are you able to access http://localhost/qlikview ? This should give you a list of demo documents that are part of the installation.

          After developing your own document you just need to place it in one of the folder assigned as document folders for QVS. Check under QEMC > Setup > QlikView Server > Folders for the path.

          (Default is C:\Documents and settings\All users\Application data\QlikTech\Documents, but on Win 7 / Vista / 2008 the folder can be found under C:\Program Data\QlikTech\Documents)

            • Display .QVW document on web

              Hi Johnnes!

              Thanks! I was also looking for the same thing. I am not able to access http://localhost/qlikview. Let me know where I am going wrong?

              Thanks and Regards,

              Rikab

                • Display .QVW document on web
                  Johannes Sunden

                  Troubleshooting is all about information. Do you get any kind of error message?

                  404 - Page not found is likely that the QVWS service is not started

                  Access denied is security related

                  Sometimes there's a small yellow warning triangle at the bottom left with additional info if just the AccessPoint outline is being loaded without any documents.

                    • Display .QVW document on web

                      This is what I got:

                       

                      <table><tbody><tr><td><h1>The page cannot be found</h1></td></tr><tr><td> The page you are looking for might have been removed, had its name changed, or is temporarily unavailable. </td></tr><tr><td> <hr/>
                      Please try the following: <ul><li>If you typed the page address in the Address bar, make sure that it is spelled correctly. </li><li>Open the <!-- if (!((window.navigator.userAgent.indexOf("MSIE") > 0) && (window.navigator.appVersion.charAt(0) == "2"))) { Homepage(); } //--> localhost home page, and then look for links to the information you want. </li><li>Click the Back button to try another link. </li></ul> <h2>HTTP 404 - File not found
                      Internet Information Services
                      </h2> <hr/>
                      Technical Information (for support personnel) <ul><li>More information:</li></ul></td></tr></tbody></table>


                      • Display .QVW document on web

                        Hello Johannnes!

                        Any idea about my problem. I did not get either of the error message which you mentioned. Let me know what may be the issue.

                        Thanks and Regards,

                        Rikab

                        • Display .QVW document on web

                          Hello Johannes!

                          Troubleshooting is all about information. Do you get any kind of error message?

                          404 - Page not found is likely that the QVWS service is not started --> Though the Access point was accessible couple of days back. Suddenly was not able to access the same from yesterday. Later after this got to know that QVWS service is not started as said you. Let me know how to start the QVWS as it was not started.

                          I also restarted the IIS and even reinstalled also but it doesn't seems to be working.

                          Thanks and Regards,

                          Rikab

                           

                            • Display .QVW document on web
                              Vlad Gutkovsky

                              Rikab,

                              The folder is hidden--either show hidden folders or navigate there directly. Regarding your service errors, check your QVS license--looks like your license was not entered or the LEF somehow got deleted. You'll probably need to enter it. Regarding the QVWS "disconnected", make sure the service is started. Are you using IIS?

                              Regards,

                                • Display .QVW document on web

                                  Hello Vlad,

                                  Thanks for your help.

                                  The folder is hidden--either show hidden folders or navigate there directly --> I have checked it but the folder is not hidden. Let me know how to navigate.

                                  Regarding your service errors, check your QVS license--looks like your license was not entered or the LEF somehow got deleted. You'll probably need to enter it.--> Yes, I don't have the server license. No idea what is LEF. Is that also one kind of license? Let me know where to enter that.

                                  Regarding the QVWS "disconnected", make sure the service is started. Are you using IIS? --> I don't know how to start the service. Yes, I am using IIS and I found is it was not functioning properly. Suddenly I am not able to access the access point page who I was able to open once couple of days back.

                                  Error while connecting the localhost:

                                   

                                  Error while connecting to the qlikview access point:

                                   

                                  Thanks and Regards,

                                  Rikab

                                    • Display .QVW document on web
                                      Community Administrator

                                       


                                      dsjain wrote:
                                      Regarding your service errors, check your QVS license--looks like your license was not entered or the LEF somehow got deleted. You'll probably need to enter it.--> Yes, I don't have the server license. No idea what is LEF. Is that also one kind of license? Let me know where to enter that. <div></div>


                                      I think this is where the main problem lies. Without a server license, the service should not start. You will need to obtain a server license (and corresponding CALs for users) before you can deploy QlikView documents.

                                        • Display .QVW document on web
                                          Vlad Gutkovsky

                                          The direct path to the example document folder is C:\documents and settings\all users\application data\qliktech\documents. To enter the license, go to QMC --> Licenses. Let's get that working first and then we'll troubleshoot the IIS error.

                                          Regards,

                                            • Display .QVW document on web

                                               


                                              Vlad Gutkovsky wrote:
                                              The direct path to the example document folder is C:\documents and settings\all users\application data\qliktech\documents. To enter the license, go to QMC --> Licenses. Let's get that working first and then we'll troubleshoot the IIS error.
                                              Regards,<div></div>


                                              I am not able to see the folder that you are talking about though i checked "Show hidden files and folders". But when i access thorough the path that you given in the run I am able to see those folder that you have mentioned. May I know why is that happening?

                                              I don't have license to enter. Let me know is there is any other way to access the document in web/locally.

                                              Thanks and Regards,

                                              Rikab

                                               

                                               

                                               

                                            • Display .QVW document on web

                                               


                                              Jason Long wrote:I think this is where the main problem lies. Without a server license, the service should not start. You will need to obtain a server license (and corresponding CALs for users) before you can deploy QlikView documents.


                                              Is it! We don't have any other license other than the desktop license. But I did able to access the "Access Point" Page but the "No Documents" were found in that page. Then how that was possible?

                                              I have seen once that QVWS server was running once but though it was not working now. If license is required to start the service then how the service was running once?

                                              Do reply

                                               

                                               

                                            • Display .QVW document on web

                                              Hi Dilip,

                                              Try to give Authorization to access your documents on "User Documents - Authorizations". Don't forget that click Apply Button.

                                              []'s

                                    • Display .QVW document on web

                                      Hi Johannes,

                                      Thanks for your suggestions!

                                      I checked and i am able to acces URL " http://localhost/qlikview ". Here i get QlikView AccessPoint page but at the bottom i get a message "No Server" with a hyperlink "Click here for possible solutions ". I tried the solutions mentioned in this hyperlink, basically verified whether QlikView Server service is started and accessible or not ,user account running the QlikViewWebServer service is member of the group "QlikView Administrators" and whether the network is available. All of these seem to be working fine.

                                      Further when i run the QlikView Enterprise Management Console, check the services, here i get the service error saying "

                                      Failed to connect to Command Center

                                      ", while when i check in Services under Computer Management all of the services seem to be running.

                                      Any idea what can be the problem here? Also i understand, till this problem is rectified and i find the foler path assigned as document foler for QVS via "QEMC > Setup > QlikView Server > Folders for the path" i will not be able to put my .qvw document in the web server and able to view in browser, am i correct, please validate?

                                      Please let me know if you need any additional information.

                                      Thanks again

                                        • Display .QVW document on web
                                          Johannes Sunden

                                          Anuragv01,

                                          There seems to be some kind of issue in you setup. Services are running but command center can't be reached and AccessPoint says "No Server". Have you restarted the server after installation? Is the account running the services a member of local administrators and QlikView administrators user groups? I would suggest contacting support at support@qlik.com who should be able to help you out.

                                          Dsjain,

                                          You are getting a 404 error which means that the page can't be found. It might be that your webserver is not up?

                                        • Display .QVW document on web

                                          Hello Johnnes!

                                          After reinstalling the IIS (Web server) I am able to access http://localhost/qlikview but it says there are "No documents". Let me know what I have to do now to see my documents here. I am so much excited! I will be happy if I see my documents here. Please help me out!

                                          Thanks and Regards,

                                          Rikab