1 Reply Latest reply: Oct 3, 2016 12:40 PM by Francis Kabinoff RSS

    "Extension:  qext was not possible to read"

    David Deutsch

      So I have been writing a visualization from scratch (Qlik desktop), and have been able to run extensions I have found elsewhere. However, my extension is not showing up, and when I finally found the correct log to search in (the system engine log), I see "Extension:  qext was not possible to read". Procmon shows that the file itself is being read, so I assume there is a parsing problem or something? I even tried tweaking a qext file that does load, and still get the problem though. FWIW, the file contents are:

       

      {

        "name": "More Current Selections",

        "description": "Object to list the current selections in the application. This can be used for exporting/printing sheets and stories where the current selections are not shown.",

        "icon": "text-image",

        "type": "visualization",

        "version": "1.1.0",

        "author": "Richard Byard / Tom Jans",

        "homepage": "",

        "keywords": "qlik-sense, visualization, current selections",

        "license": "",

        "repository": "",

        "dependencies": {

        "qlik-sense": ">=1.0.x"

        }

      }

      Any idea what the problem could be?

       

      If you don't want to hear someone whining, stop reading here

       

      <rant>

      It would be nice if Qlik would show the error on the Dev Hub interface

      It would be nice if the error message had a bit more detail than "qext was not possible to read". Give me a stack trace, inner exception, or something.

      It would be nice if there were JSON schemas and TypeScript definition files.

      It would be nice if so much of the documentation were not videos, but actual pages I could just read.

      </rant>

       

      Really sorry for the rant... just getting a bit frustrated spending hours on this stuff....