5 Replies Latest reply: Oct 26, 2016 8:19 AM by Jay Fitchett RSS

    NPrinting - Can't Generate Report

    Jay Fitchett

      Hey everyone,

      We are running the latest version of Qlik Sense, and have just installed NPrinting 17.2. We're trying to test out a report that gets emailed out. We have successfully connected to Qlik Sense. We can create the app, connection, report, and the task. We've updated the report template to include a table. Everything seems good. When I run the task manually, I receive the email but in the email I get the message:

      Some errors occurred during report generation
      Number of reports not generated: 1

      Please contact your administrator for further details

       

      I've attached the log files. They contain several warnings and emails and I can't decipher any of them. Can't find anything online. Help would be greatly appreciated!!

       

        • Re: NPrinting - Can't Generate Report
          Jay Fitchett

          After doing more research, apparently I can't have images in my report template. Is this a bug? If I can't put images into my reports, then NPrinting is pretty useless.

            • Re: NPrinting - Can't Generate Report
              RAjesh Bhardwaj

              HI Jason

               

              As far as I know, you can insert images in your header and footer. There are some size limitations to what size dimensions you can effectively use so that the image can be seen clearly. In the main body of your NPrinting report, I am assuming that the size and layouts of your QlikSense objects are obstructing the images you have already inserted in the main body, if any have been inserted, of the report as there might not be any space left for either the image of the QlikSense object.

                • Re: NPrinting - Can't Generate Report
                  Jay Fitchett

                  Thanks Rajesh. I should've been more clear. I have a bar chart in my Sense application that i want to insert as is into my Excel report. So in the template editor I had the chart as an image, then drag it into a cell. I even tried to make the cell larger. Is this not how it's supposed to work? Can I not just add my chart as an image? I'm totally new to NPrinting so it may not work this way - based on the Qlik Help videos on YouTube this appears to be how it works.

                  Also, just to test it out, I created another report for Word and tried the same thing. I resized it so it fit on the page and the same issue occurred.

                  See the attached screen shot. Appreciate the help!

                  Capture.PNG