1 Reply Latest reply: Nov 30, 2016 10:38 AM by omar bensalem RSS

    Exception while trying to restore Qlik Sense Site with RSM

    omar bensalem

      Hi everyone,
      I'm facing some troubles while trying to backup then restore a QlikSense site. Here is what I did : (I followed the help https://help.qlik.com/en-US/sense/3.1/Subsystems/PlanningQlikSenseDeployments/Content/Server/Server-Backup-Restore-Site-Using-RSM.htm)

      1) Backup: For the backup, I've chosen to work with RSM:

      a) I created a new folder in which I copied the RepositorySnapshotManager

      b) I also prepared a backup folder "BackupSense" c ) I opened the cmd , placed my self under the folder where I've put the RepositorySnapshotManager : cd "c:/RSM/" then I taped this : RepositorySnapshotManager.exe -backup -path="C:\Users\Administrateur\Desktop\BackupSense" -databasePassword="*****" (the backup is a success)

      backup.PNG

      2) I then uninstalled the QlikSense to try to restore it in the same server:

      a) I've put the Qlik_Sense_setup.exe in a folder

      b) I have my backup sense folder

      c) I then tried to restore the site by typing this in the cmd after placing my self in the folder where the rsm.exe exists: RepositorySnapshotManager.exe -restore -path=C:\Users\Administrateur\Desktop\BackupSense -installer=C:\Users\Administrateur\Desktop\InstallSense -databasePassword="****"-u="WIN-Q887L4EMVDQ\administrateur" -p="********"

      But when I do so, I have first of all a warning telling me that I haven't entered user credentials while I did : WIN-Q887L4EMVDQ\administrateur which the same user I used in the first installation

      warning.PNG

      I continue and then appear the exception:

      Capture.PNG

       

      Even with the Exception, I reinstalled the QlikSense, with the same user and password I specified in the CMD . Then, I manually copied all the backups that exists in the backup sense folder and started the services as described here :

      Capture.PNG


      But nothing seems to happen in the QMC, no users, no apps, nos streams nore security rules !

      I'm really confused ! What should I do to restore the site as it was before?

      And what is exactly meant by 'restore' the files? It's placing them (the files/folders) under the right emplacement? Right?

      As you could see, I'm really in need of a guidance ! which you'll be providing me with some !

      Thanks,

      Omar,