2 Replies Latest reply: Oct 15, 2010 7:34 PM by John De Loach RSS

    Macros with “CreateObject” never  worked

       

      Hello everybody,

      I've faced the problem since I have Windows 7 64bit version, my macros with "CreateObject" (eg. SET XLapp = CreateObject("Excel.Application"))have never worked.

       

      I get the error "ActiveX object can't be created" >> this is a translation because I have a German version.

      Does somebody know what I have to configure and how I have to configure on Windows 7?

       

      Does someone have experiences with this over Ajax-server?

      Thanks for thinking about.

      Always running scripts

       

      John D.

      Beginner

       

        • Macros with “CreateObject” never  worked
          Neil Miller

          I have Windows 7 64-bit and I was able to run a macro that user CreateObject("Excel.Application"). On the Edit Module screen, you need to make sure you have the proper security allowances. You need System Access as Requested Module Security and Allow System Access in Current Local Security. I'm not sure how those are worded in the German version. Once you have the security options properly set up, you should be able to use CreateObject.

          I don't really have any experience using them on the Ajax server.