3 Replies Latest reply: Aug 4, 2017 1:42 PM by Mark Ritter RSS

    "Failed to add data" - folder connection issue

    Slava Malchenko

      Hey Guys! I'm new with Qlik products and I struggle with a simple task when I need to load data from xlsx file to Qlik Desktop.

      I've created an app in desktop hub and folder connection. Everything is ok when I upload the file

      2016-12-05_1421.png

      But when I click "prepare data" here comes the error

      2016-12-05_1422.png

      Connection established in the standart folder C:\Users\username\Documents\Qlik\Sense\Apps

      I've tried to connect another folder on drive D: but no results

      Maybe the problem relates with user roles, because I'm not admin and can't change it. Please assist.

        • Re: "Failed to add data" - folder connection issue
          Finbar Gillen

          I have the same issue..tried to import from Oracle connection as well but with no luck! Any help greatly appreciated.

            • Re: "Failed to add data" - folder connection issue
              Mark Ritter

              I don't use Oracle.  But have set up many data connections with SQL.

               

              Have you confirmed that the connection actually works?  If it does work then at what point are you having a problem?

               

              I still do it the old way.  I typically don't use the Data Manager.  But if you pick The data load editor instead of 'Add Data' then when that opens you should see your Oracle data connection on the right side.  There should be a button to Select Data.  Click on that and then you should be able to see the tables in your database.  If you get this far then the connection itself is working.

               

              Select any table.

              Then select insert script.  The code should now show up in your script editor. 

              Click on Load Data in top right corner.

               

              If everything is setup correctly your data should load and then you can open the App and build some visualizations.

            • Re: "Failed to add data" - folder connection issue
              Mark Ritter

              Have you tried just dragging the excel file onto the app when you create it instead of creating a connection.  Let QS do the work.