2 Replies Latest reply: Nov 24, 2010 3:30 AM by Qlikview-tester RSS

    Problem etting TIMESTAMP(6)

      Hi,

       

      are there any problem getting TIMESTAMP(6) data from an Oracle Database? I always get an error!

      I've tried with ODBC and OLEDB...

       

      If I try to "select" fields using script editor I can't see any field from the TIMESTAMP one (included)...

       

      Thank you!

       

       

        • Problem etting TIMESTAMP(6)
          Fernando Toledo

          I always use TO_DATE function when extracting dates from oracle to avoid this kind of errors

            • Problem etting TIMESTAMP(6)

              Could you give an example, please? (This is the first time I'm doing an SQL Query...):

              I use a simple query where datetime field is an TIMESTAMP(6) value with this format 'YYYY-MM-DD hh:mm:ss.fff',

               

              I've tried to use that query but it seems that it doesn't accept the format:

              LOAD HOST, DATE_C;
              SQL SELECT HOST, TO_DATE(DATE_C,'AAAA-MM-DD hh:mm:ss.fff')
              from TABLE1;

              Ans this is the error: SQL##f - SqlState: S1000, ErrorCode: 1821, ErrorMsg: [Oracle][ODBC][Ora]ORA-01821: date format not recognized

               

               

              Thank you so much!